Feature #20508

Enable stdWrap on select properties groupBy and orderBy

Added by Oliver Hader about 12 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2009-05-26
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

The TypoScript select properties groupBy and orderBy do not support stdWrap functionality.

TSref [tsref:->select]
Change datatype of properties 'groupBy' and 'orderBy' to:
'SQL-orderBy / stdWrap'
(issue imported from #M11193)


Files

0011193.patch (864 Bytes) 0011193.patch Administrator Admin, 2009-05-26 18:32

Related issues

Related to TYPO3 Core - Bug #20529: stdWrap for TypoSrcrip-select parametersClosed2009-05-29

Actions
Is duplicate of TYPO3 Core - Feature #24089: Optimize stdWrap usage for tslib_contentClosedSusanne Moog2010-11-17

Actions
Has duplicate TYPO3 Core - Bug #46272: Typoscript CONTENT-Element orderBy doesn't consider stdWrapClosed2013-03-14

Actions
#1

Updated by tyler kraft almost 12 years ago

Hi Oliver,

I just wanted to check if this was going to be included in 4.3? If so is it possible to instead extend it and include issue #20529 as that would greatly increase the select functionality.

Best,
Tyler

#2

Updated by Myroslav Holyak over 10 years ago

Omg. Last update date is 06.05.10, there was so many new versions of core from that time.And this change is so small but so good. Cant' it be applied in for e.g. 4.4.5?

#3

Updated by Jo Hasenau over 10 years ago

It's been implemented during the stdWrap optimization process for 4.5

Can be closed.

#4

Updated by Susanne Moog about 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF