Feature #46460

Introduce TCA displayCond type "USER"

Added by Sebastian Michaelsen about 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-03-20
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

With displayCond you can evaluate each form field whether it should be displayed or not. There is a number of options, but you can't define a UserFunction if the options provided by the core don't fit your needs.

Usage example:
'displayCond' => 'USER:\\MyVendor\\MyExt\\UserFunction\\MyClass->displayCondition'


Related issues

Is duplicate of TYPO3 Core - Bug #62944: displayCond should allow userFunc as conditionClosed2014-11-14

Actions
Blocked by TYPO3 Core - Task #46461: Extract displayCond functionality from FormEngine to new classClosed2013-03-20

Actions
#1

Updated by Sebastian Fischer almost 7 years ago

How is the current status on this issue?

#2

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Resolved

We have a mostly similar issue that has some more input in it.
We'll continue there.
The request is not forgotten.

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF