Bug #62944

displayCond should allow userFunc as condition

Added by Sebastian Fischer over 4 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2014-11-14
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Would be great to have userFuncs usable in TCA displayCond.
By this it would be possible to have custom rules implemented wether a field should get shown or not


Related issues

Duplicated by TYPO3 Core - Feature #46460: Introduce TCA displayCond type "USER" Closed 2013-03-20

Associated revisions

Revision cdcf56c8 (diff)
Added by Sebastian Fischer over 4 years ago

[FEATURE] displayCond should allow userFunc as condition

This patch enables the usage of a displayCond defined as
'USER:\Example\Namespace\UserClass->functionName:any:other:parameter'

Releases: master
Resolves: #62944
Change-Id: I9e915e9098494715a3fb5961836af6b16eb12b27
Reviewed-on: http://review.typo3.org/34728
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Sebastian Fischer over 4 years ago

The userFunc should get handed the following informations:
if new:
-tablename
-fieldname
-fieldconfig
-currentPageId

if already saved once:
-tablename
-fieldname
-fieldconfig
-currentPageId
-currentRecordData

Return Value would be boolean as its just a decision if the field should be displayed or not.
The userFunc should be called with TYPO3\CMS\Core\Utility\GeneralUtility::callUserFunction to have the same handling like every other userfunc

Example for a configuration would be
'displayCond' => 'USER:\Example\Namespace\UserClass->functionName:REQ:true',

#2 Updated by Benni Mack over 4 years ago

Want to implement this? Would be great!

#3 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34728

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34728

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34728

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34728

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34728

#8 Updated by Wouter Wolters over 4 years ago

  • Status changed from Under Review to Resolved

#9 Updated by José Ricardo over 4 years ago

As an additional feature, I suggest extending this to sheets.
The solution seems to be simple, just adding the case 'USER': in the switch on method getSingleField_typeFlex at TYPO3\CMS\Backend\Form\FormEngine.php

#10 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF