Bug #4681

unclear wording and maybe another error too

Added by Georg Ringer over 11 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Category:
scheduler
Target version:
-
Start date:
2009-09-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I am trying to get a new task and something fails and the error msg says: "Execution of task "check4 exts - server (check4exts)" failed with the following message: Task failed to execute successfully. Class: tx_check4exts_server, UID: 3"

1st problem: wording: UID 3 is nice but in the view "scheduled task" there is no column "uid". So either delete the information from the error text or better add the uid col to the table. This doesn't need much space but would be certainly nice.

2nd problem: after creating the task I get the error message "The selected task class could not be found. You should probably contact the task's developers." The problem is that this message won't be shown to the user again anymore! If the user proceeds, there is no way to get to this message anymore without deleting the task and create it again. if this error is so important it should be stated somewhere again or the task won't be created.

funny 3rd problem: the task works, cause a mail function inside the execute() sends me a mail but I still get the error in the backend (as written in the beginning of the report here)


Files

#1

Updated by Georg Ringer over 11 years ago

sample ext added, tested on current trunk of TYPO3

#2

Updated by Francois Suter over 11 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Francois Suter

Hi Georg,

I agree that the UID should be displayed. I will add it.

About your task failing to execute, it's because you don't return a status from the execute() method. It's supposed to return a boolean, true if it succeeded. So it runs, but reports falsely. RTFM ;-)

About point 2, I didn't get that message. Can you give me the precise steps you took?

#3

Updated by Georg Ringer over 11 years ago

Hi,

so the wording is wrong because it really can be that the task will be executed. it should be more something like "the status is unclear, nothing returned".

point 2: maybe it is really not reproduceable because it could have been because of a mistake with autoloader because I created the file after placing the hook + creating the task ;) anyway what would be the way without using the autoloader?

#4

Updated by Francois Suter over 11 years ago

Hi,

so the wording is wrong because it really can be that the task will be executed. it should be more something like "the status is unclear, nothing returned".

I don't agree. The tasks are expected to return a boolean. It's written in the manual and in the phpDoc of the execute() method of tx_scheduler_Task. It's the programmer's fault in this case.

point 2: maybe it is really not reproduceable because it could have been because of a mistake with autoloader because I created the file after placing the hook + creating the task ;) anyway what would be the way without using the autoloader?

You can't. The Scheduler expects task classes to be available via the autoloader. Again all that is explained in the manual and developers should follow the guidelines to create properly working tasks.

#5

Updated by Georg Ringer over 11 years ago

ok all my fault - your explanation makes sense!

#6

Updated by Francois Suter over 11 years ago

  • Status changed from Needs Feedback to Closed

Move to the main TYPO3 bug tracker, see:

http://bugs.typo3.org/view.php?id=12010

#7

Updated by Michael Stucki about 7 years ago

  • Category set to scheduler
#8

Updated by Michael Stucki about 7 years ago

  • Project changed from Scheduler to TYPO3 Core
  • Category changed from scheduler to scheduler

Also available in: Atom PDF