Project

General

Profile

Actions

Bug #47222

closed

Uncaught TYPO3 Exception in RTE when using FAL makes the tceform unusable for editors

Added by Christian Eßl about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-04-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYP3 6.0.4

1.) Create a content element that uses rte in the backend.
2.) In the rte create a link to a file or a path that doesn't exist (anymore).
3.) Save and reload the tceform.

You will get this error:

Uncaught TYPO3 Exception

TYPO3\CMS\Core\Resource\Exception\FileDoesNotExistException thrown in file
/var/www/vhosts/domain.com/httpdocs/typo3/sysext/core/Classes/Resource/Driver/AbstractDriver.php in line 399.

14 TYPO3\CMS\Core\Resource\Driver\AbstractDriver::getFile("veranstaltungen/seminarpauschalen/")

This makes it virtually impossible to use TYPO3 6.0 as an editor right now, because the editor has no way to fix this minor mistake in the link. You would have to directly edit the database field in an external tool because tceform itself becomes unusable.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #48956: Copying a link to a non-exisiting location into the text editor throws errorClosed2013-06-08

Actions
Related to TYPO3 Core - Bug #48181: Opening an image wit text element fails after update to 6.0.xClosed2013-05-14

Actions
Is duplicate of TYPO3 Core - Bug #46785: FileDoesNotExistException ClosedAlexander Opitz2013-03-29

Actions
Actions #1

Updated by Ben van 't Ende about 11 years ago

I can confirm similar behaviour in 6.1beta2. I changed the path for an image in the RTE, because of failed migration and that throws this error:

#1320575630: Folder migrated/RTE/RTEmagicC_inspiring-flow-head_01.png.png does not exist. (More information)
TYPO3\CMS\Core\Resource\Exception\FolderDoesNotExistException thrown in file
/home/typo3_src/typo3_src-6.1.0beta2/typo3/sysext/core/Classes/Resource/ResourceStorage.php in line 1638.
Actions #2

Updated by Sebastian Koch about 11 years ago

As a temporary(!!!) work around to fix the corrupted link just change the code in the following way:

// THIS IS line 399 in AbstractDriver.php
public function getFile($identifier) {
<------><------>$fileObject = NULL;
<------><------>if (!$this->fileExists($identifier)) {
// TEMPORARY FIX Remove Exception handling
<------><------>//<---->throw new \TYPO3\CMS\Core\Resource\Exception\FileDoesNot
// RETURN NULL
<------><------>return null;
<------><------>}
<------><------>$fileInfo = $this->getFileInfoByIdentifier($identifier);
<------><------>$fileObject = $this->getFileObject($fileInfo);
<------><------>return $fileObject;
<------>}

Now you can edit the link and then better move back to the original code.

Actions #3

Updated by Philipp Müller about 11 years ago

Also in 6.0.5

Actions #4

Updated by Alexander Opitz about 11 years ago

  • Status changed from New to Closed

Closed as duplicate of #46785

Actions #5

Updated by Gerrit Code Review about 11 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20570

Actions #6

Updated by Alexander Opitz about 11 years ago

  • Status changed from Under Review to Closed
Actions #7

Updated by Simon Schick about 11 years ago

I got this exception when creating an external link to a page having the same domain-name as the page managed in TYPO3. Because I use seo-friendly URLs, the URL must have looked like a folder to the system ... and because it had a domain that was registered to this TYPO3 instance, it tried to open it as a folder ...

Don't know if this issue should be addressed anywhere else ... I think external links are not worth checking, are they?

Actions

Also available in: Atom PDF