Bug #48332

uploading extname_1.0.3 (1).zip creates extension extname (1)

Added by Stefano Cecere about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2013-05-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

i download my developed extension from local machine.
it gets named: extname_1.0.3.zip

i upload to my server and it installs extension: extname

if then i download again the same extension, and it gets renamed (by OSX but i guess every OS renames duplicates) to extname_1.0.3 (1).zip

when i upload this extension to my server.. it automatically installs extension "extname (1)" !!

it seems that it takes the extension name from the file, and not from the unzipped folder (as old em did)

#1

Updated by Jigal van Hemert about 8 years ago

  • Status changed from New to Needs Feedback

The filename must have the format <extensionKey>_<version>.zip ; in the zip-file (as provided by both TER and the EM) there is no folder with the extension name.
Do you have any suggestions where to reliably get the extension key from the contents of the zip file?
The .t3x file contains extra information where the EM can find the extension key.

#2

Updated by Stefano Cecere about 8 years ago

Hi Jigal
how can you say that the extension filename MUST have format format <extensionKey>_<version>.zip ??

this is a new thing since 6.0, right? i don't remember to have read anything about this (quite big changing) new behavior
because em has always accepted any kind of filenames.. and it has been useful for backup purpose, to name locale, dev and prod exts etc)

the extension name is, and has always been, its folder name.

if i unzip "extname_1.0.3.zip" and "extname_1.0.3 (1).zip" , what i get is and should always be a folder named "extname"

am i wrong?

#3

Updated by Jigal van Hemert about 8 years ago

EM supports two file types for upload:
- zip; format: <extensionKey>_<version>.zip
- t3x; file name irrelevant, information about extension key is included inside file

You can download either format from the extension manager. From TER all extensions are in t3x format available, some/most are also in zip files available.

#4

Updated by Stefano Cecere about 8 years ago

ahhh

i understood that .t3x was to be abandoned, and since 6.0 the standard format is .zip, which is far better for everybody
since this, i have been dealing with .zip only

i guess we should not support both formats forever. but for sure the .zip filename format should be more open.. at least:

<extensionKey>_<version>_<whatever-i-want>.zip

what do you think?

#5

Updated by Stefano Cecere about 8 years ago

PS: anyway from EM i can only download .zip format.. this is why i got the problem!

#6

Updated by Philipp Gampe about 8 years ago

  • Status changed from Needs Feedback to Accepted
  • Assignee set to Philipp Gampe
  • % Done changed from 0 to 80
  • Complexity set to no-brainer

We can drop anything behind the version as we are only interested in the extension key.

#7

Updated by Gerrit Code Review about 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20875

#8

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20875

#9

Updated by Philipp Gampe about 8 years ago

Please test this change.

#10

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20875

#11

Updated by Gerrit Code Review about 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20875

#12

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21077

#13

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/21078

#14

Updated by Philipp Gampe about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 80 to 100
#15

Updated by Jan Kornblum almost 8 years ago

Hmm, what does "resolved" mean in this context? It is still not possible to rename / add anything behind the zipfiles version number as importing this extension will result in a wrong extension key.

In addition, using the download-button in extension manager should relly again create a filename containing a timestamp (as old extension manager used to do: extkey_version_yyddmm or similar).

#16

Updated by Philipp Gampe almost 8 years ago

Jan Schröder you can add anything you want after the version number and it will be ignored. Only the part before the version number is used for the extension key. Take a look at the unit test.

Regarding the timestamp in the download file, please create a new issue for this. This is really easy to implement.

#17

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF