Task #49300

Ensure PHP 5.5 compatibility

Added by Markus Klein about 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2013-06-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Sprint Focus:


Related issues

Precedes TYPO3 Core - Bug #52771: RemoveXSS uses deprecated /e modifier in preg_replaceClosedJigal van Hemert2013-10-14

Actions
#1

Updated by Markus Klein about 8 years ago

Checked all code occurrences.

Only one issue with preg_replace in GeneralUtility::substUrlsInPlainText().

#2

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21556

#3

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21556

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21556

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22315

#6

Updated by Markus Klein about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF