Bug #49585

Invalid cache backend option "compression" for backend of type NullBackend

Added by Xavier Perseguers about 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2013-07-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In a TYPO3 4.6, I deactivated the default cache with:

$TYPO3_CONF_VARS['SYS']['caching']['cacheConfigurations']['cache_pages']['backend'] = 't3lib_cache_backend_NullBackend';
$TYPO3_CONF_VARS['SYS']['caching']['cacheConfigurations']['cache_pagesection']['backend'] = 't3lib_cache_backend_NullBackend';

This setting is then migrated to LocalConfiguration.php but since 4.7, compression is set to TRUE for the Typo3DatabaseBackend. As the caching configuration is recursively merged and NullBackend does not handle the compression flag, an fatal error is thrown.


Related issues

Related to TYPO3 Core - Bug #65149: Invalid cache backend option "compression" for backend of type \TYPO3\CMS\Core\Cache\Backend\FileBackendClosed2015-02-18

Actions

Also available in: Atom PDF