Bug #65149

Invalid cache backend option "compression" for backend of type \TYPO3\CMS\Core\Cache\Backend\FileBackend

Added by Joerg Boesche over 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Caching
Target version:
Start date:
2015-02-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

If I change the caching mechanism in the LocalConfiguration.php, I'm getting the following exception.

LocalConfiguration.php,

'SYS' => array(
        'caching' => array(
            'cacheConfigurations' => array(
                               'cache_pages' => array(
                    'backend' => 'TYPO3\\CMS\\Core\\Cache\\Backend\FileBackend',
                    'frontend' => 'TYPO3\\CMS\\Core\\Cache\\Frontend\\VariableFrontend',
                    'options' => array(
                    ),
                ),
                ),
            ),

 #1231267498: Invalid cache backend option "compression" for backend of type \TYPO3\CMS\Core\Cache\Backend\FileBackend

I think there has to be patched the \TYPO3\CMS\Core\Cache\Backend\AbstractBackend class with an additional method "setCompression()".
Most of the CacheBackends are extending the AbstractBackend.

In an old "Bug #49585: https://forge.typo3.org/issues/49585" the NullBackend was fixed.

Can you fix it for all the CacheBackends please?


Related issues

Related to TYPO3 Core - Bug #49585: Invalid cache backend option "compression" for backend of type NullBackendClosedXavier Perseguers2013-07-02

Actions
Related to TYPO3 Core - Bug #65153: Fatal in install tool if options have been set for cache_classes or cache_coreClosed2015-02-18

Actions
#1

Updated by Christian Kuhn over 6 years ago

No, we can not add compression to the default abstract class since not every backend that extends from it does implement this option.

I wonder why setting options to an emty array does not work in your case ... I'll try to dig into a bit.

BTW: I stumbled upon a different issue: If you have options set for cache_classes or cache_core, the install tool will fail ... this is actually a bug and I'll push a patch for that.

#2

Updated by Christian Kuhn over 6 years ago

Solution:

'cache_pages' => array(
    'backend' => 'TYPO3\\CMS\\Core\\Cache\\Backend\FileBackend',
    'frontend' => 'TYPO3\\CMS\\Core\\Cache\\Frontend\\VariableFrontend',
    'options' => array(
        'compression' => '__UNSET',
    ),
),
#3

Updated by Christian Kuhn over 6 years ago

  • Status changed from New to Resolved

I know the solution is not obvious - I added a remark to my todo list to improve the documentation in this regard. There is no other way than this at the moment due to the logic on how DefaultConfiguration.php and LocalConfiguration.php are merged.

I guess the issue is solved with this, so I'll close the ticket.

#4

Updated by Joerg Boesche over 6 years ago

Thanks for your help, fixing and explaining the problem.
The "__UNSET"-Value works like a charm!

#5

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF