Bug #49712

When deflangBinding is not used, the copy button logic is inverted

Added by Georg Ringer almost 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2013-07-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the changes of #42768 the logic of defLangBinding is inverted when it is set to 0 (which is default).

Now the button "copy default elements" is shown when nothing is to be copied and is missing if content elements are available in default language but not in the target language.


Related issues

Related to TYPO3 Core - Bug #42768: multilanguage content elements (language "all") not shown anymore if defLangBinding is usedClosed2012-11-07

Actions
Related to TYPO3 Core - Bug #42771: Languages view (Web->Page) is unusable with multilanguage content elements since 4.7.5Closed2012-11-07

Actions
#1

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22015

#2

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22015

#3

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22015

#4

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22354

#5

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22355

#6

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22354

#7

Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22355

#8

Updated by Stefan Galinski almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF