Bug #50065

file:current does not merge properties

Added by Philipp Bergsmann over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-07-16
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Given a file has a description and an alternative set in the filelist-module it gets merged with the override-values in the reference. this is not the case when the keyword "current" is used.

E.g.:

altText.data = file:current:description

does not work

altText.data = file:{file:current:originalUid}:description
altText.data.insertData = 1

does work

History

#1 Updated by Philipp Bergsmann over 6 years ago

Full TS-sample:

lib.aNewCe.renderImage = FILES
lib.aNewCe.renderImage {
references {
table = tt_content
uid.data = field:contentUid
fieldName = image
}
renderObj = COA
renderObj {
10 = IMAGE
10 {
file {
import.data = file:current:originalUid
}
altText.data = file:current:description
}
}
}

#2 Updated by Mathias Schreiber almost 5 years ago

  • Target version set to 7.1 (Cleanup)
  • Is Regression set to No
  • Sprint Focus set to On Location Sprint

#3 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#4 Updated by Alina Fleser over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Alina Fleser

#5 Updated by Alina Fleser over 4 years ago

I can't reproduce this issue on master.

Test results:

altText.data = file:current:description
Displays the description of the file reference
altText.data = file:{file:current:originalUid}:description
altText.data.insertData = 1

Displays the description of the original file

The output seams to be correct

#6 Updated by Christian Kuhn over 4 years ago

  • Status changed from In Progress to Closed

Thanks Alina.

Closed as "unable to reproduce" now. Philipp, if you think, this was the wrong decision, you are free to re-open this issue or create a new one and mention this one.

#7 Updated by Mathias Schreiber over 4 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF