Bug #50576

Page view should scroll when using drag&drop on pages higher than the viewport

Added by Benjamin no-lastname-given about 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-07-30
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When reaching bottom or top of the page while dragging a content element the page should scroll to make it possible to drop the content anywhere on the page.

Associated revisions

Revision e90d3d7d (diff)
Added by Benni Mack over 5 years ago

[TASK] Use jQuery UI for Drag&Drop in Page Module

In the process to move away from ExtJS
and fixing some open problems, the JS
code for the drag+drop functionality in the
page module is rewritten based on jQuery UI.

In addition to having a RequireJS module,
the new JS-based DataHandler AJAX call
is used. Also, a content element is only
moved in the HTML code, if the AJAX result
is true. Scrolling works as well, which resolves
the existing problem from forge ticket #50576.

Resolves: #50576
Resolves: #64221
Releases: master
Change-Id: I19cdbf4820d16606125ec908cc7fe4d34df415da
Reviewed-on: http://review.typo3.org/35807
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Ernesto Baschny about 7 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • Priority changed from Must have to Should have
  • Complexity set to medium

Indeed would be a nice enhancement to the page module.

#2 Updated by Ernesto Baschny about 7 years ago

Jigal is working on that here at the CMS Sprint in Essen. Not so easy as the ExtJS drag&drop is difficult to configure, but he is trying hard. :)

#3 Updated by Jo Hasenau about 7 years ago

We already got that for Gridelements 1.x and 2.x so maybe we can do something about it during the Gridelements weekend.
Otherwise Jigal might want to take a look at the code and just copy the appropriate parts.

IIRC one of the workarounds for a usable D&D + scrolling was to define a surrounding container as "display:table", since the D&D area was restricted to 100% width and height of the currently visible part, which made it impossible to drop anything outside that area, even though scrolling itself worked fine.

#4 Updated by Ernesto Baschny about 7 years ago

  • Tracker changed from Feature to Bug

This is indeed not solved yet, I think Jigal has not managed to finish his work on this. It would be great - Joey - if you could provide some patch for fixing this in the core. thanks!

#5 Updated by Jo Hasenau about 6 years ago

Will be a task for the user experience week - should be easy to implement.

#6 Updated by Jo Hasenau about 6 years ago

On the other hand: It's ACME - so maybe we can even tackle that here in Munich ;-)

#7 Updated by Gerrit Code Review about 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32681

#8 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32681

#9 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35807

#10 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35807

#11 Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35807

#12 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35807

#13 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35807

#14 Updated by Benni Mack over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Denis Mir over 5 years ago

This bug is still available in the 6.2 LTS which makes it awful to work with.

#16 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF