Bug #51099

Epic #65814: Make Indexed search extbase plugin shine

Streamline settings/conditions

Added by Thomas Skierlo about 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Indexed Search
Target version:
-
Start date:
2013-08-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

Currently indexed_search is a pure mess of old- and new school features, and the experimental template is showing less than could be expected. The reason for that is evident:

old school: plugin.tx_indexedsearch.show.rules

Fluid: plugin.tx_indexedsearch.settings.displayRules

and a Rules partial starting with:

<f:if condition="{settings.showRules}">

Associated revisions

Revision 01ffb0c4 (diff)
Added by Ludwig Rafelsberger over 3 years ago

[BUGFIX] Use correct setting to display search rules

The extbase plugin (pi2) of EXT:indexed_search previously used a
different TypoScript setting to control the display of search rules
than the setting that is shipped as default TypoScript. This changes
the template to use the correct setting.

Resolves: #51099
Releases: master, 7.6
Change-Id: I893ff0c85a3bc9fde885cbb5103d9ebf54e488a2
Reviewed-on: https://review.typo3.org/46002
Reviewed-by: Bernhard Kraft <>
Reviewed-by: Wouter Wolters <>
Tested-by: Bernhard Kraft <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

Revision 5b8609ff (diff)
Added by Ludwig Rafelsberger over 3 years ago

[BUGFIX] Use correct setting to display search rules

The extbase plugin (pi2) of EXT:indexed_search previously used a
different TypoScript setting to control the display of search rules
than the setting that is shipped as default TypoScript. This changes
the template to use the correct setting.

Resolves: #51099
Releases: master, 7.6
Change-Id: I893ff0c85a3bc9fde885cbb5103d9ebf54e488a2
Reviewed-on: https://review.typo3.org/46002
Reviewed-by: Bernhard Kraft <kraftb@think-open.at>
Reviewed-by: Wouter Wolters <typo3@wouterwolters.nl>
Tested-by: Bernhard Kraft <kraftb@think-open.at>
Reviewed-by: Morton Jonuschat <m.jonuschat@mojocode.de>
Tested-by: Morton Jonuschat <m.jonuschat@mojocode.de>
(cherry picked from commit 01ffb0c45ae4894f74d25a39e96bdd7b0dc683da)
Reviewed-on: https://review.typo3.org/46009

Revision 13b77351 (diff)
Added by Wouter Wolters over 3 years ago

[FOLLOWUP] Use correct setting to display search rules

Move documentation into 7.6 folder

Resolves: #51099
Releases: 7.6
Change-Id: I3af0bec71f82c7933999fbb9d08c2a9536999e52
Reviewed-on: https://review.typo3.org/46010
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Philipp Gampe about 6 years ago

  • Status changed from New to Needs Feedback

What do you expect us to do? Improve the template or provide more meaningful settings?

You may also propose a patch: http://wiki.typo3.org/CWT

#2 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#3 Updated by Tymoteusz Motylewski over 4 years ago

  • Status changed from Closed to Accepted
  • Parent task set to #65814

#4 Updated by Tymoteusz Motylewski over 3 years ago

either condition in the template has to be changed to {settings.displayRules}
or the TS has to be changed to "showRules = 1"

#5 Updated by Tymoteusz Motylewski over 3 years ago

  • Complexity set to no-brainer

#6 Updated by Ludwig Rafelsberger over 3 years ago

  • Assignee set to Ludwig Rafelsberger
  • TYPO3 Version changed from 6.1 to 7

Did some research on since when this inconsistency exists:

TYPO3 4.5

TypoScript:

plugin.tx_indexedsearch.show.rules = 1

code correctly uses $this->conf['show.']['rules']

since TYPO3 6.2

TypoScript:
ext_typoscript_setup.txt:

plugin.tx_indexedsearch.show.rules = 1

Configuration/TypoScript/setup.txt:

plugin.tx_indexedsearch.settings.displayRules = 1

Pi1 (classic search plugin):

code correctly uses $this->conf['show.']['rules']

Pi2 (experimental extbase variant):
Fluid uses wrong variable <f:if condition="{settings.showRules}>

looks like we need to treat a fix as breaking change.

#7 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46002

#8 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46002

#9 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46002

#10 Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46009

#11 Updated by Ludwig Rafelsberger over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46010

#13 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46010

#14 Updated by Ludwig Rafelsberger over 3 years ago

  • Status changed from Under Review to Resolved

#15 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF