Bug #51360

Linkvalidator: specifying TSconfig in scheduler has no effect

Added by Sybille Peters about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
Linkvalidator
Target version:
-
Start date:
2013-08-26
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It is possible to set for example subject and content type via page TSconfig. This works fine. However, setting TSconfig in linkvalidator task in scheduler has no effect.

Using version TYPO3 4.5.29

linkvalidator.png View (32.8 KB) Sybille Peters, 2013-12-20 09:30

Associated revisions

Revision ae05d796 (diff)
Added by Alexander Stehlik over 4 years ago

[BUGFIX] Use mod.linkvalidator settings in scheduler

Since mod.linkvalidator is used in all other places in the linkvalidator
as TSConfig key it is now also used in the scheduler to override existing
TSConfig.

To maintain backward compatibility the old mod.tx_linkvalidator setting
will be respected and a deprecation warning will be logged.

Resolves: #51360
Releases: master
Change-Id: I6e6692d2ff6543f1154e4d64feb52efc5cdfcf83
Reviewed-on: http://review.typo3.org/26513
Reviewed-by: Benjamin Mack <>
Reviewed-by: Wouter Wolters <>
Tested-by: Benjamin Mack <>
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>

History

#1 Updated by Michael Stucki almost 6 years ago

  • Category set to Linkvalidator

#2 Updated by Michael Stucki almost 6 years ago

  • Project changed from Linkvalidator to TYPO3 Core
  • Category changed from Linkvalidator to Linkvalidator

#3 Updated by Alexander Stehlik almost 6 years ago

Please note that the Page TSConfig that is used depends on the "Start page (uid)" setting in the scheduler task.

So please make sure that your Page TSConfig is active in the page you specified in the task settings.

I tested it with TYPO3 4.7 and there it seems to work.

Cheers,
Alex

#4 Updated by Sybille Peters almost 6 years ago

I'm not sure you understand my problem. I am trying to use the page TSconfig field in the scheduler settings for linkvalidator. It seems to have no effect at all.

I'm using pid=0 and it should run over several page trees in one installation.

Using a specific pid and specifying TSconfig for that page works. That is not the problem here.

#5 Updated by Alexander Stehlik almost 6 years ago

Ahh, sorry, I totally missed the point.

I think I found the problem and this seems to be indeed a bug.

Currently the configuration key used for overriding TSConfig is called:

mod.tx_linkvalidator

Please note the tx_ prefix, which is not present in the "normal" TSConfig.

Can you please try again using mod.tx_linkvalidator instead of mod.linkvalidator?

#6 Updated by Sybille Peters almost 6 years ago

Yes, mod.tx_linkvalidator works. Thanks.

#7 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26513

#8 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26513

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26513

#10 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/26513

#11 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/26513

#12 Updated by Alexander Stehlik over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF