Bug #51509

Missing API interface FileInterface::getNameWithoutExtension

Added by Ernesto Baschny about 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-08-29
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The method getNameWithoutExtension was added to the interface FileInterface in #41768. It was implemented correctly, but due to a syntax error in the closing phpdoc comment header it was never officially part of the interface.

We need to fix this. Undecided yet if we will backport that addition to 6.1 and 6.0, but it seems to make sense.

Most classes will probably subclass AbstractFile which already contains this methods, so there shouldn't be a problem for these. Only affected classes could be extensions implementing the interface directly.


Related issues

Related to TYPO3 Core - Task #41768: File: add getFilenameWithoutExtensionFile() Closed 2012-10-09

Associated revisions

Revision b0bbacfc (diff)
Added by Ernesto Baschny about 6 years ago

[BUGFIX] Add missing API method FileInterface::getNameWithoutExtension

This method was supposed to be in the interface, but due to a syntax
error in the closing comment tag, it was not (and was not detected as a
PHP syntax error).

This finally adds this method and implements it also in the class
FileReference which hadn't had this method before but also implements
this interface.

Resolves: #51509
Releases: 6.2, 6.1, 6.0
Change-Id: I8ee1ecc155e9cfaeec7ac0ac7086f75df13f4c34
Reviewed-on: https://review.typo3.org/23453
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring

Revision 182e5cdd (diff)
Added by Ernesto Baschny about 6 years ago

[BUGFIX] Add missing API method FileInterface::getNameWithoutExtension

This method was supposed to be in the interface, but due to a syntax
error in the closing comment tag, it was not (and was not detected as a
PHP syntax error).

This finally adds this method and implements it also in the class
FileReference which hadn't had this method before but also implements
this interface.

Resolves: #51509
Releases: 6.2, 6.1, 6.0
Change-Id: I8ee1ecc155e9cfaeec7ac0ac7086f75df13f4c34
Reviewed-on: https://review.typo3.org/23454
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring

Revision f1ab4995 (diff)
Added by Ernesto Baschny about 6 years ago

[BUGFIX] Add missing API method FileInterface::getNameWithoutExtension

This method was supposed to be in the interface, but due to a syntax
error in the closing comment tag, it was not (and was not detected as a
PHP syntax error).

This finally adds this method and implements it also in the class
FileReference which hadn't had this method before but also implements
this interface.

Resolves: #51509
Releases: 6.2, 6.1, 6.0
Change-Id: I8ee1ecc155e9cfaeec7ac0ac7086f75df13f4c34
Reviewed-on: https://review.typo3.org/23454
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring
(cherry picked from commit 182e5cdd02acf6b27fc3fc17670dfdfa61d6bbf6)
Reviewed-on: https://review.typo3.org/23455

History

#1 Updated by Gerrit Code Review about 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23453

#2 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23453

#3 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23454

#4 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/23455

#5 Updated by Ernesto Baschny about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF