Project

General

Profile

Actions

Bug #52204

closed

Epic #68397: Make TYPO3 work with MySQL strict mode

SQL error: Incorrect integer value: '' for column 'backend_layout

Added by Stefan Neufeind over 10 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-09-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

SQL error: 'Incorrect integer value: '' for column 'backend_layout' at row 1' (pages:NEW12345)

This happens for me on master when trying to create a new page either by drag-n-drop in the page-tree or the new-wizard.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #52206: Default-values for text-fieldsClosed2013-09-24

Actions
Related to TYPO3 Core - Bug #18866: Cannot create page with Mysl in strict mode (STRICT_TRANS_TABLES)RejectedAlexander Opitz2008-05-28

Actions
Related to TYPO3 Core - Task #54883: Document that TYPO3 CMS is not compatible with MySQL strict modesClosedErnesto Baschny2014-01-09

Actions
Actions #1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24007

Actions #2

Updated by Stefan Neufeind over 10 years ago

for 4.5/4.7 this is in: t3lib/stddb/tbl_pages.php

It didn't occur to me on regular installations, so I wonder if maybe newer MySQL-releases are a bit more picky about trying to set an empty string for a integer-column. But it's wrong with trying to set a string there anyhow ...
Happened to me locally with Fedora 19 using mariadb-server-5.5.32-8.fc19

Actions #3

Updated by Stefan Neufeind over 10 years ago

Turns out that from recent system-environment-testing I still had "sql-mode = STRICT_ALL_TABLES" in my.cnf. Removing that makes the problem go away. Still fix it since it's "wrong"?

Actions #4

Updated by Stefan Neufeind over 10 years ago

  • Status changed from Under Review to Rejected

Only happens with "sql-mode = STRICT_ALL_TABLES" which is not suggested. Georg mentioned on gerrit that the new dataproviders might/will/... work with strings anyway then. Not needed to have this patch.

Actions #5

Updated by Axel Dörfler over 10 years ago

Any chance to reconsider this decision for older version? It's no help for current (even LTS) users to keep this bug around. MySQL, and MariaDB are configured in strict mode by default.

Actions #6

Updated by Axel Dörfler over 10 years ago

An alternative solution would be to be able to set the SQL_MODE for the session from within Typo3 -- it may not always be possible to influence the global SQL_MODE that is used on hosting solutions.

Actions #7

Updated by Stefan Neufeind over 10 years ago

Hmm, default on your hosting-environment or really a MySQL-default? Do you know since what versions?

Actions #8

Updated by Patrik Nasfors about 10 years ago

Strict mode is a MySQL default on Windows at least since version 5.0.

Actions #9

Updated by Jörg Wagner about 10 years ago

Strict mode is also the default on Mac when using the current MySQL installer packages (mysql-5.6.17-osx10.7-x86_64.dmg).

Actions #10

Updated by Morton Jonuschat almost 9 years ago

  • Parent task set to #68397
Actions

Also available in: Atom PDF