Bug #52859

Extension Manager / Get Extensions / Fatal error: Call to a member function getUid() on a non-object / missing object $this->repository

Added by Wolfgang Klinger over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2013-10-15
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

fresh installation throws exception:

Fatal error: Call to a member function getUid() on a non-object in /var/www/test/typo3/6.1.5/typo3/sysext/extensionmanager/Classes/Utility/Repository/Helper.php on line 251 Call Stack: 0.0007 336476 1. {main}() /var/www/test/typo3/6.1.5/typo3/mod.php:0 0.2352 5551740 2. TYPO3\CMS\Extbase\Core\ModuleRunner->callModule() /var/www/test/typo3/6.1.5/typo3/mod.php:47 0.2371 5564300 3. TYPO3\CMS\Extbase\Core\Bootstrap->run() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Core/ModuleRunner.php:81 0.3330 6691956 4. TYPO3\CMS\Extbase\Core\Bootstrap->handleRequest() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Core/Bootstrap.php:197 0.3488 6804104 5. TYPO3\CMS\Extbase\Mvc\Web\BackendRequestHandler->handleRequest() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Core/Bootstrap.php:208 0.3597 7019624 6. TYPO3\CMS\Extbase\Mvc\Dispatcher->dispatch() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Mvc/Web/BackendRequestHandler.php:47 0.4510 9290300 7. TYPO3\CMS\Extbase\Mvc\Controller\ActionController->processRequest() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Mvc/Dispatcher.php:100 0.5618 11061444 8. TYPO3\CMS\Extbase\Mvc\Controller\ActionController->callActionMethod() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Mvc/Controller/ActionController.php:186 0.5620 11063228 9. call_user_func_array() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Mvc/Controller/ActionController.php:285 0.5620 11063480 10. TYPO3\CMS\Extensionmanager\Controller\UpdateFromTerController->updateExtensionListFromTerAction() /var/www/test/typo3/6.1.5/typo3/sysext/extbase/Classes/Mvc/Controller/ActionController.php:0 0.5699 11120844 11. TYPO3\CMS\Extensionmanager\Utility\Repository\Helper->updateExtList() /var/www/test/typo3/6.1.5/typo3/sysext/extensionmanager/Classes/Controller/UpdateFromTerController.php:106 0.5699 11120888 12. TYPO3\CMS\Extensionmanager\Utility\Repository\Helper->isExtListUpdateNecessary() /var/www/test/typo3/6.1.5/typo3/sysext/extensionmanager/Classes/Utility/Repository/Helper.php:279

line 251:

if ($this->extensionRepository->countByRepository($this->repository->getUid()) <= 0) {

$this->repository is null

History

#1 Updated by Wouter Wolters over 5 years ago

  • Status changed from New to Needs Feedback

Did you run the upgrade wizard?
The repository data needs to be inserted into the database to be able to download extensions.

#2 Updated by Wolfgang Klinger about 5 years ago

Thanks for the hint,
it’s not obvious (at least for me) to run the Update wizard for a brand new installation(?)

#3 Updated by Markus Klein about 5 years ago

  • Status changed from Needs Feedback to Closed

Seems to be solved

#4 Updated by Julian Hofmann about 5 years ago

After trying to reproduce the error, we have found the problem: While the initial install routine creates the database structure and inserts additional data, creating the database structure via "Install Tool -> Database Analyser -> COMPARE" creates only the structure (ext_tables.sql) but not the additional data in this structure (ext_tables_static+adt.sql).
Our database had been manually deleted due to an error and had been created once again via compare. In this case we got the error above. With a really new installation everthing was fine.

#5 Updated by Benjamin Rau almost 5 years ago

Id like to add a short description how to fix this because this issue is one of the first results on google:

  • Open typo3/sysext/extensionmanager/ext_tables_static+adt.sql and copy the INSERT sql statement from there.
  • Run this sql on your typo3 database
  • Your extension manager should work again

For the lazy ones, try this sql statement:
INSERT INTO tx_extensionmanager_domain_model_repository VALUES ('1', '0', 'TYPO3.org Main Repository', 'Main repository on typo3.org. This repository has some mirrors configured which are available with the mirror url.', 'http://typo3.org/wsdl/tx_ter_wsdl.php', 'http://repositories.typo3.org/mirrors.xml.gz', '1346191200', '0');

Also available in: Atom PDF