Bug #53527

Illegal string offset in ext_tables.php

Added by Stefan Froemken over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2013-11-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

since updating from PHP 5.3 to PHP 5.4 we get following errors just after each Clear Cache:

Warning: Illegal string offset 'gb_weather_pi1' in /kunden/removedPath/typo3conf/ext/gb_weather/ext_tables.php on line 26
Warning: Illegal string offset 'pagebrowse_pi1' in /kunden/removedPath/typo3conf/ext/pagebrowse/ext_tables.php on line 8
Warning: Illegal string offset 'itaw_youtoubeembed_pi1' in /kunden/removedPath/typo3conf/ext/itaw_youtoubeembed/ext_tables.php on line 37
Warning: Illegal string offset 'kc_emailnotification_pi1' in /kunden/removedPath/typo3conf/ext/kc_emailnotification/ext_tables.php on line 65
Warning: Illegal string offset 'tt_address_pi1' in /kunden/removedPath/typo3conf/ext/tt_address/ext_tables.php on line 89

The mentions lines are:

$TCA["tt_content"]["types"]["list"]["subtypes_excludelist"][$_EXTKEY."_pi1"]="layout";
$TCA['tt_content']['types']['list']['subtypes_excludelist'][$_EXTKEY . '_pi1'] = 'layout,select_key,pages';
...

"subtype_addlist" was never a problem. So only "subtypes_excludelist" throws these Warnings.

Stefan

#1

Updated by Markus Klein over 7 years ago

This means that $TCA["tt_content"]["types"]["list"]["subtypes_excludelist"] is not an array but a string.

@Stefan: Is it correct that you're running TYPO3 CMS 6.2 and upgraded from PHP 5.3 to 5.4?

#2

Updated by Stefan Froemken over 7 years ago

Thank you Markus,

I have found the bug while searching in ext_tables.php_cached_cdnjkwh43r4578gh45.php

$TCA['tt_content']['types']['list']['subtypes_excludelist'] = 'layout,select_key,pages,recursive';

I have changed it to:

$TCA['tt_content']['types']['list']['subtypes_excludelist'][$_EXTKEY.'_glossar'] = 'layout,select_key,pages,recursive';

You're right. Jochen has changed today morning PHP-Version for a TYPO3 6.2 from 5.3 to 5.4.

Stefan

#3

Updated by Tomita Militaru over 7 years ago

The problem seems to be in one of your extensions then and it's not related to TYPO3 core.

#4

Updated by Stefan Froemken over 7 years ago

Yes...it was a bug in one of my extensions. You can close this issue.

Stefan

#5

Updated by Stefan Galinski over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF