Bug #53974

Environment variables prefixed with REDIRECT_ ignored

Added by Mathias Brodala about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-11-26
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using Apache mod_rewrite in certain setups (mostly PHP in CGI mode) makes environment variables from original requests available in the target request as REDIRECT_<envvar>, thus e.g. setting TYPO3_DISABLED_CORE_UPDATER becomes REDIRECT_TYPO3_DISABLED_CORE_UPDATER.

This should be handled transparently by GeneralUtility::getIndpEnv() and relevant locations be updated (e.g. TYPO3_CONTEXT, TYPO3_DISABLE_CORE_UPDATER).


Related issues

Related to TYPO3 Core - Bug #58358: Use REDIRECT_TYPO3_CONTEXT as fallback for TYPO3_CONTEXT environment variable Closed 2014-04-30
Precedes TYPO3 Core - Bug #53188: REDIRECT_TYPO3_DISABLE_CORE_UPDATER ignored Closed 2013-11-27 2013-11-27

Associated revisions

Revision f2ef9fab (diff)
Added by Steffen Müller over 5 years ago

[BUGFIX] Use REDIRECT_ prefix as fallback for environment variables

The core uses values of environment variables for
disabling the core updater and to determine the
application context.

When setting the variable with mod_rewrite, certain server environments
prefix the variable name with REDIRECT_.
To ensure compatibility for this case, REDIRECT_
prefix is prepended as a fallback if the regular
variable is not set.

Resolves: #53188
Resolves: #58358
Resolves: #53974
Releases: 6.2
Change-Id: Iaba7f936ff1362d1f70426ec8ad1b1821e4e0d3c
Reviewed-on: https://review.typo3.org/25123
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Steffen Müller
Tested-by: Steffen Müller

History

#1 Updated by Mathias Brodala about 6 years ago

What would be the impact including GeneralUtility into \Core\Bootstrap::getInstance() to handle REDIRECT_TYPO3_CONTEXT?

#2 Updated by Chris topher over 5 years ago

  • Status changed from New to Closed
  • Target version deleted (6.2.0)

Duplicate of #53188.

#3 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Closed to Under Review

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25123

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25123

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25123

#6 Updated by Steffen Müller over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF