Bug #54849

Epic #55070: Workpackages

Epic #54851: WP: Workspaces IRRE & MM bugfixes

Epic #55064: WP: Workspaces test cases / DataHandler bugfixes

Functional tests cannot write to backend log

Added by Oliver Hader almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Tests
Target version:
Start date:
2014-01-08
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Functional test cases cannot write to the backend log. The log entry also has an information about the currently used IP address, which is taken from the environment variable REMOTE_ADDR. In a CLI disposal this value is NULL and cannot stored in the database, since the accordant sys_log.IP field does not support NULL values.


Related issues

Related to TYPO3 Core - Feature #54850: Set REMOTE_ADDR even when in CLI mode Rejected 2014-01-08
Related to TYPO3 Core - Bug #53662: DatabaseConnection INSERTquery does not allow NULL values Closed 2013-11-15

Associated revisions

Revision 270a7eaa (diff)
Added by Oliver Hader almost 6 years ago

[BUGFIX] Functional tests cannot write to backend log

Functional test cases cannot write to the backend log. The
log entry also has an information about the currently used
IP address, which is taken from the environment variable
REMOTE_ADDR. In a CLI disposal this value is NULL and cannot
be stored in the database, since the accordant sys_log.IP
field does not support NULL values.

Fixes: #54849
Releases: 6.2
Change-Id: If6c572c62ab7022a4cab596fa4660dec754aee3c
Reviewed-on: https://review.typo3.org/26697
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

Revision 57b70f79 (diff)
Added by Oliver Hader almost 6 years ago

[BUGFIX] CLI context cannot write to backend log

The CLI context cannot write to the backend log. The
log entry also has an information about the currently used
IP address, which is taken from the environment variable
REMOTE_ADDR. In a CLI disposal this value is NULL and cannot
be stored in the database, since the accordant sys_log.IP
field does not support NULL values.

Note: Already merged in master (6.2) with different subject:
[BUGFIX] Functional tests cannot write to backend log

Fixes: #54849
Releases: 6.2, 6.1, 6.0
Change-Id: If6c572c62ab7022a4cab596fa4660dec754aee3c
Reviewed-on: https://review.typo3.org/27022
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 68057cfd (diff)
Added by Oliver Hader almost 6 years ago

[BUGFIX] CLI context cannot write to backend log

The CLI context cannot write to the backend log. The
log entry also has an information about the currently used
IP address, which is taken from the environment variable
REMOTE_ADDR. In a CLI disposal this value is NULL and cannot
be stored in the database, since the accordant sys_log.IP
field does not support NULL values.

Note: Already merged in master (6.2) with different subject:
[BUGFIX] Functional tests cannot write to backend log

Fixes: #54849
Releases: 6.2, 6.1, 6.0
Change-Id: If6c572c62ab7022a4cab596fa4660dec754aee3c
Reviewed-on: https://review.typo3.org/27023
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26697

#2 Updated by Oliver Hader almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27022

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27023

#5 Updated by Oliver Hader almost 6 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Oliver Hader over 5 years ago

  • Parent task set to #54852

#7 Updated by Oliver Hader over 5 years ago

  • Parent task changed from #54852 to #55064

#8 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF