Bug #54913

Sorting of media elements in page->resources not reflected after re-ordering

Added by Robert Wildling over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2014-01-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Setup:
MAMP 2 Pro | php 5.5.3 | TYPO3 CMS 6.2.0beta3 (but also in 6.1) | APC

Scenario:
I added 2 image files in the media field if the first page.
This TypoScript reads the files to 2 different div-containers (listNum is 0, then 1):

  1. get the images

lib.IMAGE_01 = IMG_RESOURCE
lib.IMAGE_01 {
stdWrap.wrap = <img src="|" />
file {
import.data = levelmedia: -1, slide
import.listNum = 0
treatIdAsReference = 1
}
}
lib.IMAGE_02 < lib.IMAGE_01
lib.IMAGE_02.file.import.listNum = 1

  1. Fluid Templates

FluidTemplate = FLUIDTEMPLATE
FluidTemplate {
file = fileadmin/FluidTemplate/Private/index.html
layoutRootPath = fileadmin/FluidTemplate/Private/Layouts/
layoutPartialsPath = fileadmin/FluidTemplate/Private/Partials/
variables {
IMAGE_01 < lib.IMAGE_01
IMAGE_02 < lib.IMAGE_02
}
}

Initially, everything works fine. But when the 2 image files a re-ordered (the first one becomes the second and vice verca), then - after saving and clearing all caches - the new ordering is ignored in the front end.

Thank you for your efforts!
Best regards, Robert


Related issues

Is duplicate of TYPO3 Core - Bug #54884: RootlineUtility does not consider foreign_sorting for relation fieldsClosedMarkus Klein2014-01-09

Actions
#1

Updated by Markus Klein over 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (Markus Klein)
  • Target version deleted (6.2.0)

Closing as duplicate of #54884

Also available in: Atom PDF