Bug #55263

Labels of all extjs buttons are invisible

Added by Stefan Froemken over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-01-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hello Core-Team,

when I try to delete an installed extension in extension manager then a dialog appears with two buttons. But there is no label "yes" and "no".
I have seen that you have renamed t3lib_l10n-folder to l10n in typo3temp/Cache/Data/. I have deleted this folder. But labels are still empty. Further I have removed this folder again and received all new languages from languageserver. Labels are still not there.

So, this is not a Cache thing. It's a bug

Stefan


All extjs buttons are affected. The font-size is 0.


Files

ie8-pagetree.PNG (11.1 KB) ie8-pagetree.PNG Stephan Großberndt, 2014-01-30 19:16

Related issues

Related to TYPO3 Core - Task #52497: Simplify Font-Size inheritance (CSS)Closed2013-10-03

Actions
#1

Updated by Markus Klein over 7 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version changed from 6.2.0 to next-patchlevel
#2

Updated by Markus Klein over 7 years ago

The labels are there. The font-size is 0!!

#3

Updated by Markus Klein over 7 years ago

Felix, can you please take a look at this?

#4

Updated by Markus Klein over 7 years ago

  • Subject changed from Confirmation labels in EM missing to Labels of all extjs buttons are invisible
  • Category changed from Extension Manager to Backend User Interface
  • Complexity deleted (no-brainer)
  • Is Regression changed from No to Yes
#5

Updated by Stephan Großberndt over 7 years ago

This is due to ext-all-notheme.css

.x-window-bc .x-window-footer {
    font-size: 0;
    line-height: 0;
}

This was formerly overridden in /typo3/sysext/t3skin/extjs/xtheme-t3skin.css with

.x-btn button {
       font-size: 11px;        
}

but removed in https://review.typo3.org/#/c/24299/

#6

Updated by Stephan Großberndt over 7 years ago

In Internet Explorer versions below 10 the labels of pages in the page tree are invisible.

This is due to

.ext-ie UL.x-tree-node-ct {
       line-height: 0;
       font-size: 0px;
}

which was formerly overridden in /typo3/sysext/t3skin/extjs/xtheme-t3skin.css with

.x-tree-node {
       color:#000;
       font: normal 10px verdana, arial, tahoma, helvetica, sans-serif;        
}

but removed in https://review.typo3.org/#/c/24299/

#7

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27166

#8

Updated by Stephan Großberndt over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF