Bug #55352

TYPO3 breaks if docblock is removed by opcode cache

Added by Alexander Opitz over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
-
Start date:
2014-01-27
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It is possible with Zend OPcache, Zend Optimizer+ and eAccelerator to remove the docblock from the cached opcode. But this is needed for Extbase & Fluid.

What we get on install:

PHP Fatal error: Call to a member function get() on a non-object in /home/opitz/projects/typo3-test/typo3-src/typo3/sysext/install/Classes/Controller/Action/AbstractAction.php on line 78

We should check this separately and only in the 123 install tool before startup.


Related issues

Related to TYPO3 Core - Bug #55252: PHP 5.5 and require LocalConfiguration Closed 2014-01-22
Related to TYPO3 Core - Task #72724: Drop fluid FailSafe from install tool Closed 2016-01-15

Associated revisions

Revision 81e7fcba (diff)
Added by Helmut Hummel over 5 years ago

[BUGFIX] Introduce failsafe view in install tool

The installer does not work, if doc comment reflection
is broken, so we need to make the first install step
more robust by using inject methods and introducing
a failsafe view which does simple php templating
in case critical errors (like doc comments disabled)
occur.

Resolves: #55352
Releases: 6.2
Change-Id: I424d6a290b65ae023ec19a745477cfaecdef72c7
Reviewed-on: https://review.typo3.org/27067
Tested-by: Alexander Opitz
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 82b03615 (diff)
Added by Christian Kuhn almost 4 years ago

[TASK] Drop fluid FailSafe from install tool

Install tool has a fallback layer to a php based template
in case fluid does not work due to broken reflection for
@inject annotations. Since @inject isn't used anymore in
install tool this layer can be dropped now.

Change-Id: Iedf0e9ea75fa105f649324c993963fb29e666607
Resolves: #72724
Related: #55352
Releases: master
Reviewed-on: https://review.typo3.org/45868
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Alexander Opitz over 5 years ago

  • Category changed from Miscellaneous to Install Tool

#2 Updated by Alexander Opitz over 5 years ago

In the class TYPO3\CMS\Install\SystemEnvironment\Check we have the function "checkReflectionDocComment()" but this test is to late.

#3 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#6 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#7 Updated by Gerrit Code Review over 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#11 Updated by Gerrit Code Review over 5 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#12 Updated by Gerrit Code Review over 5 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27067

#13 Updated by Helmut Hummel over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF