Bug #55392

Missing opcode cache throws warning (instead of notice) and triggers mail

Added by conenergy agentur over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-01-28
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you run TYPO3 on a system without opcode cache (as in many shared hosting environments, e.g. Mittwald), the install tool registers this and shows a warning.

I'd say while APC is certainly a very good addon and everyone should try to use it with TYPO3 because of performance, sadly not everyone can use it. The system runs fine without. Nothing to really "warn" about.

Also, if you have a cronjob running each night, triggering the scheduler running a "report" task, you will get a mail with (by the way 2) failed tests/warnings each night.

It is only a tiny change neccesary:
File typo3/sysext/install/Classes/SystemEnvironment/Check.php

Line 747:
change from
$status = new WarningStatus();
to
$status = new NoticeStatus();


Related issues

Related to TYPO3 Core - Bug #55252: PHP 5.5 and require LocalConfiguration Closed 2014-01-22
Related to TYPO3 Core - Bug #55694: System-status-updates sends emails about same "errors" over and over again New 2014-02-05

Associated revisions

Revision 9c35421b (diff)
Added by Sebastian Müller over 5 years ago

[BUGFIX] Change notification level for missing opcode cache

Now the notification level is set to notice instead of warning.
Therefore no email notification will be send if the user has not
set his cache or his cache has only medium performance

Resolves: #55392
Releases: 6.2
Change-Id: I90758ba658477a4b92f1a110228eb7950648ec39
Reviewed-on: https://review.typo3.org/28216
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

History

#1 Updated by Markus Klein over 5 years ago

  • Status changed from New to Accepted
  • Target version set to next-patchlevel
  • Estimated time deleted (0.50 h)

Hi!

We intended to change that with #55252.
Currently it is being discussed whether this should be Warning or Notice, but your point is very valid.

#2 Updated by Alexander Opitz over 5 years ago

  • Complexity deleted (no-brainer)

I would like to discuss this issue here, as #55252 addresses a very different problem.

At first I'd like to know, what is the difference between error and warning, beside the fact that they have different colors in the install and report tool.

So I have 3 solutions in my mind:

1) Only report Error in the mail (to get a difference in handling for error/warning).

2) Add functionality to acknowledge Errors/Warnings, so they don't get mailed every time (and maybe show them in another style in install/report).

3) Change opcode cache check from Warning to Notice, but get more attention on notices in installer.

1) and 3) would be easy but 2) would be perfect also for other errors/warnings.

Any more solutions around?

#3 Updated by Alexander Opitz over 5 years ago

For example the "PHP Maximum upload filesize too small" Error is something I know on some systems and I do not need any report about that.

#4 Updated by Stefan Neufeind over 5 years ago

Maybe #55694 is a dupe of that.

#5 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28216

#6 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28216

#7 Updated by Sebastian Müller over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF