Bug #55763

using object as string in ResourceStorage->getUniqueName

Added by Tymoteusz Motylewski over 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2014-02-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

I got this error while attaching file in RTE
"Object of class TYPO3\CMS\Core\Resource\Folder could not be converted to string"

it is caused by the call
if (!$this->driver->fileExistsInFolder($theDestFile, $folder)) {
which should look like:
if (!$this->driver->fileExistsInFolder($theDestFile, $folder->getIdentifier())) {

because $folder is an object.


Related issues

Has duplicate TYPO3 Core - Bug #55766: PHP Catchable Fatal Error: Object of class TYPO3\CMS\Core\Resource\Folder could not be converted to string in LocalDriver.php line 677ClosedFrans Saris2014-02-07

Actions
#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27412

#2

Updated by Tymoteusz Motylewski over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#3

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF