Bug #55877

Property ListUtility::$objectManager does not exist

Added by Pascal Dürsteler about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2014-02-11
Due date:
% Done:

50%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Using 6.2.0beta5, I get the following error message when trying to use the extension manager:

Property TYPO3\CMS\Extensionmanager\Utility\ListUtility::$objectManager does not exist 

This seems to belong to beta5, since I don't have the problem on a beta4 setup.

clearCache.png View (88.6 KB) Oliver Hader, 2014-02-11 19:27


Related issues

Related to TYPO3 Core - Story #54991: Improve caching framework by introducing groups Closed 2014-01-15
Related to TYPO3 Core - Bug #69619: Property TYPO3\CMS\Extensionmanager\Service\ExtensionManagementService::$listUtility does not exist Closed 2015-09-08

History

#1 Updated by Christian Clemens about 6 years ago

I can confirm this...

#2 Updated by Oliver Hader about 6 years ago

  • Status changed from New to Accepted

I can confirm this...

#3 Updated by Oliver Hader about 6 years ago

  • File clearCache.png added

Since the last beta version, the "flush all caches" button in the backend does not consider the internal system caches (it was different in earlier TYPO3 CMS versions).
However, due to performance reasons the caches have been separated to runtime caches and internal system caches - system caches are not cleared automatically.

Solution
Enter the Install Tool, open "Important Actions" section and click the "Clear all Caches" button there

#4 Updated by Oliver Hader about 6 years ago

  • File deleted (clearCache.png)

#5 Updated by Oliver Hader about 6 years ago

#6 Updated by Oliver Hader about 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee set to Oliver Hader
  • Priority changed from Must have to Should have
  • % Done changed from 0 to 50
  • PHP Version set to 5.3
  • Complexity set to easy

Please let me know whether the round-trip in the Install Tool solved your problem. Thanks in advance!

#7 Updated by Christian Clemens about 6 years ago

Thank you for your quick response! I've tried clear caches as described, but install tool detected many incompatible extension. I don't think, they are really incompatible, because I had no problems with them, also not under 6.2beta5. And: sometimes 1 extension was mentioned, sometimes 3 extension.

Now I have downgraded to 6.2beta4, but extension manager does still not work. Message appears is now:

Property TYPO3\CMS\Extensionmanager\Utility\ListUtility::$packageManager does not exist

ReflectionException thrown in file
/is/htdocs/wp11035062_LVJ7Z06IPY/www/typo3_src-6.2.0beta4/typo3/sysext/extbase/Classes/Reflection/PropertyReflection.php in line 47.

If I remember correctly, I've got the same message before downgrading and after clearing caches as described.

Do you have any idea how to get the extension manager to work again?

#8 Updated by Pascal Dürsteler about 6 years ago

Hi Oli

Yes, that roundtrip solved the problem, thanks.

#9 Updated by Christian Clemens almost 6 years ago

I have the same problem again after upgrading from 6.2beta4 to 6.2.2. "Clear all Caches" in install tool does not solve the problem for me - the error message still apears.

But: I'm using "APC cache backend" instead of "Database cache backend". If I switch back to "Database cache backend", then the error suddenly dissappears.

The solution for this problem is: writing a small php file which clears the APC-Cache:

<?php
apc_clear_cache ();
apc_clear_cache('user'); 
apc_clear_cache('opcode');
?>


I think, this should be inserted in the TYPO3 code for "Clear all Caches" in install tool, too.

#10 Updated by Christian Clemens almost 6 years ago

Ah, there is already a button "Clear PHP Opcode Cache" below the button "Clear all Caches". I have not tested this button yet, but it will solve the problem, too, I think ;-)

#11 Updated by Alexander Opitz over 5 years ago

Hi,

was this issue fixed with TYPO3 6.2.4 or does it still exists?

Or better, does the implemented "Clear PHP opcode cache" button helps?

#12 Updated by Pascal Dürsteler over 5 years ago

Hi Alex

I'd say so. At least in the latest two 6.2.4 setups I had, I didn't encounter that one.

#13 Updated by Christian Clemens over 5 years ago

With the "Clear PHP opcode cache" button everything is fine!

#14 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Oliver Hader)
  • Target version deleted (6.2.0)

Thanks for your feedback.

Also available in: Atom PDF