Project

General

Profile

Actions

Bug #56077

closed

Blocking errors if files deleted

Added by Thomas Sperling over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-02-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you delete files on the server (without TYPO3) you can get blocking errors as editor.

My specific case was the thumbnails of tt_news in listview. If the connected image does not exist you get an error ('File xyz does not exist' thrown in LocalDriver) at the whole list-view (instead of a warning). As a limited editor it is almost impossible to fix this error.

I researched and found out that this problem occurs on some places (more or less).

I use TYPO3 6.2beta5.

I'am not sure if it is related to FAL, but i think it is no tt_news-problem.
To reproduce: Create news and link image (i uploaded it initially). Then i used an regular editor backend user. In list view i got this error.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #56147: Regenerate missing RTE magic image on renderingClosed2014-02-20

Actions
Actions #1

Updated by Thomas Sperling over 10 years ago

I forgott: For reproducing, you have to delete the file of course.

Actions #2

Updated by Frans Saris over 10 years ago

  • Status changed from New to Needs Feedback

For this we added the missing flag feature that is set by the file indexer schedular task.

If you (re)move files direct on filesystem it is recomended to have thuis schedular task run once in a while.

Could you try that and when it still rails post the exception here?

Actions #3

Updated by Markus Klein over 10 years ago

@Frans: Ok, but this is IMO no solution.
What if some person deletes a file and the index regenerated 3 hours later?
In the meantime the BE (and probably other places) is broken.

As a user I'd expect graceful degradation, like a warning somewhere.

Actions #4

Updated by Markus Klein over 10 years ago

  • Status changed from Needs Feedback to Accepted
Actions #5

Updated by Frans Saris over 10 years ago

Markus,

During some testing I found out that the missing flag isn't the solution here. So I agree with you that this should be fix.

Gr. Frans

Actions #6

Updated by Steffen Ritter over 10 years ago

@Markus: that is a solution - if you allow anybody (your server, your editor, ftp -whatever) to manage files OUTSIDE the TYPO3 file module you are obligated to have the indexer task running.

The whole concept of FAL is based on the expectation, that the sys_file table always is sync with the file-system (reliably). This promise needs to be kept.
Everything which goes wrong because this indexer task is not run frequently enough and changes happened outside TYPO3 - it's not a core fault.

If the missing flag at some places is not enough - than we need to improve the usage of that - of course, but not if it even is not flagged as missing.

Actions #7

Updated by Frans Saris over 10 years ago

Problem is that TYPO3\CMS\Backend\Utility\BackendUtility::thumbCode() doesn't catch the exception. Working on a patch for that now.

Actions #8

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28284

Actions #9

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28284

Actions #10

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28284

Actions #11

Updated by Gerrit Code Review over 10 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28284

Actions #12

Updated by Frans Saris over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF