Bug #56135

Exception in listQuery in DatabaseConnection never thrown

Added by Stefano Kowalke over 8 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
Start date:
2014-02-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

The condition should check for comma in $value in the method listQuery. This will not work because the parameters of strpos are in wrong order.

It need to be:

strpos($haystack, $needle) 

but we have:

strpos($needle, $haystack) 

if (strpos(',', $value) !== FALSE) {
    throw new \InvalidArgumentException('$value must not contain a comma (,) in $this->listQuery() !', 1294585862);
}

Related issues

Related to TYPO3 Core - Bug #56160: Exception in listQuery in DatabaseConnection never thrown (TYPO3 4.x)Closed2014-02-20

Actions

Also available in: Atom PDF