Bug #56380

The extension xxx is not available from TER. But its already installed!!

Added by Christopher Seidel over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-02-27
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

in the 6.2 extensionmanager (beta 5) i have the following bug:

The extension flux is not available from TER.
But flux is already installed manually as you can see in the screenshot.

It seems the dependencies are only checked against TER and not against already installed extensions.

confusing_bug.PNG View (15.1 KB) Christopher Seidel, 2014-02-27 13:59


Related issues

Duplicated by TYPO3 Core - Bug #47743: Error if local extension depends on another local extension Closed 2013-04-30

History

#1 Updated by Markus Klein over 5 years ago

So this can be tested by having and extension installed, which is generally available from TER, but the locally installed version has a different dependency setting?

#2 Updated by Christopher Seidel over 5 years ago

Yes thats correct

#3 Updated by Christopher Seidel over 5 years ago

So for example in TER is flux only available for TYPO3 version 6.1.99
I installed the new Flux manually with dependency for 6.2 and above.

fluidcontent now has only the dependy for flux (no version number is given!). But the install fails because he wants to import flux from the TER where it cant be installed from, due to version conflict with the TYPO3 Version

#4 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Closed

dupe of #47743

Also available in: Atom PDF