Bug #56860

RTE page browser jumps to external URL on fold / unfolding the pagetree

Added by Alexander Stehlik about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-03-13
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When you try to unfold or fold the pagetree in the RTE link browser in the page mode the browser will always jump to the external URL tab.

This is a regression from #56470


Related issues

Related to TYPO3 Core - Task #55983: Cleanup init() function of ElementBrowser Closed 2014-02-14

Associated revisions

Revision ec4f5449 (diff)
Added by Alexander Stehlik about 6 years ago

[BUGFIX] JavaScript generation in RTE element browser

The JavaScript in the RTE element browser is now initialized at the
end of the initialization process to make sure that all required
class variables (like $this->act) are initialized.

Resolves: #56860
Releases: 6.2
Change-Id: I39d3223921c5b17cffb31d98d62f02fa46663d27
Reviewed-on: https://review.typo3.org/28338
Reviewed-by: Tymoteusz Motylewski
Tested-by: Tymoteusz Motylewski
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Alexander Stehlik about 6 years ago

Sorry, my fault, regression is from #55983.

The JavaScript code is initialized too early when not all required class variables (like act) are initialized.

#2 Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28338

#3 Updated by Alexander Stehlik about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF