Bug #56990

If user is admin, the home directory of users and groups are not mounted

Added by Marc Bastian Heinrichs over 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-03-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

For a normal user it is working correct since https://review.typo3.org/#/c/23597/


Related issues

Related to TYPO3 Core - Bug #57587: Admin BE user records should ignore db mountsClosed2014-04-03

Actions
#1

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

Not sure if this behavior is intended.
It will for sure lead to some nasty JS issues.

#2

Updated by Alexander Opitz over 6 years ago

What's the state of this issue?

#3

Updated by Mathias Schreiber over 6 years ago

  • Status changed from Needs Feedback to Rejected

We discussed that in a group with UX people and also techs and architects and decided to not allow, nor "fix" this.

#4

Updated by Marc Bastian Heinrichs over 6 years ago

The issue is still valid.

I could not really follow the UX guys.
To know your user uid and to know the uids of the groups you are in and for what they are as an admin is IMO not usefull.
To not show normal mountpoints is okay, because you have normally speaking folder names, but user/group dirs are only numbers.
University sites have normally more than a handful groups. And for sure this could be optional.

#5

Updated by Mathias Schreiber over 6 years ago

I wonder if we all get your description wrong.
So I am an admin user and for whatever reason I also have BE groups.
You then want the FILE mounts of these groups to show up in filelist although you have full access already.

That's how we all understood the report.

#6

Updated by Marc Bastian Heinrichs over 6 years ago

The report is about this feature:

$GLOBALS['TYPO3_CONF_VARS']['BE']['userHomePath']
$GLOBALS['TYPO3_CONF_VARS']['BE']['groupHomePath']

Autom. mount points for users and groups matching an folder by uid.

Also available in: Atom PDF