Project

General

Profile

Actions

Bug #57375

closed

The ext impexp is mandatory to install a distribution

Added by Eric Chavaillaz almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2014-03-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

If you want to install a distibution, you must have the extension "impexp" (perhaps others?) installed. Otherwise a fatl error is thown.

A easy solution is that the option in the select box of the extension manager must not show the link to the preconfigured distribution if this extension is not installed. But it's not safe because it's possible to call the right URL directly.

An other solution, must safer, is to ask the user to install the extension before seeing the distribution choices.

Thanks

Actions #1

Updated by Xavier Perseguers almost 10 years ago

  • Status changed from New to Accepted
  • Assignee set to Benni Mack
Actions #2

Updated by Philipp Gampe almost 10 years ago

I would even automatically install the impexp extension while installing a distribution. Maybe we can just add it to the list of runtime activated packages?
Otherwise just install impext if a distribution is attempt to be installed.

Actions #3

Updated by Eric Chavaillaz almost 10 years ago

Activate the extension during an installation is good. But I am not sure that's a good idea to decide for the user. For me the user must be informed that the extension will be installed if he try to use a distribution...

Actions #4

Updated by Ernesto Baschny almost 10 years ago

  • Assignee deleted (Benni Mack)

I would suggest that the "Get Distribution" page should not show any distribution list if impexp is not installed, but only a button to install the "Importer / Exporter" extension and some explanation about it. So then you can click on the button, and after reload you see the list of distributions. What do you think?

Good catch! I've added this issue to the list of important to fix: http://forge.typo3.org/projects/typo3cms-v62/wiki/Issues

Actions #5

Updated by Eric Chavaillaz almost 10 years ago

For me it would be the best solution.

Thanks

Actions #6

Updated by Nicole Cordes almost 10 years ago

  • Assignee set to Nicole Cordes
Actions #7

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29781

Actions #8

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29781

Actions #9

Updated by Gerrit Code Review almost 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29781

Actions #10

Updated by Nicole Cordes almost 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #11

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF