Bug #57472

FAL multiple file upload: not all images are uploaded

Added by Alexander Dick over 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-04-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I upload multiple images for example in the default "Images" content element, they get uploaded but afterwards only 3 are actually assigned to the content element, see screenshots.

I have also tested this with a custom content element (flux/fluidcontent), same behavior.
maxItems of the fal element is set to 100, but this does not seem to have any impact.

Tested in Chrome 33, Firefox 28 and IE 11. In IE 11 only 2 images are added instead of 3.


Files

1.jpg (134 KB) 1.jpg while uploading Alexander Dick, 2014-04-01 08:37
2.jpg (116 KB) 2.jpg after upload Alexander Dick, 2014-04-01 08:37

Related issues

Related to TYPO3 Core - Bug #57190: 6.2.0rc1 Image Upload into CE -> uncompleteClosed2014-03-22

Actions
Related to TYPO3 Core - Bug #58956: Only one Image saved after multiple uploadClosedFrans Saris2014-05-20

Actions
#1

Updated by Alexander Dick over 7 years ago

Occurs also at the media field in the page properties.

#2

Updated by Claus Due over 7 years ago

Confirmed; Chrome 33. After upload only a single image is left. No dev console error messages are shown. Uploading images one by one works flawlessly.

#3

Updated by jochen kast over 7 years ago

Same issue on contentelement filelinks. uploaded three pdf-files only one file assigned, but all files are corretly uploaded.
tested in ie11 + ff28

#4

Updated by Alexander Dick over 7 years ago

  • Assignee deleted (Benni Mack)

Any news on this?

#5

Updated by Sebastian Fischer over 7 years ago

Works for me. Tested with three images at once in fileadmin and in page properties media on chrome 34.0.1847.132

#6

Updated by Alexander Dick over 7 years ago

Sebastian Kurfuerst Fischer
please try repeatedly and with more images (5-10), does it still work every time?

#7

Updated by Frans Saris over 7 years ago

  • Status changed from New to Needs Feedback

Could you check if #58956 resolves your issue?

#8

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30609

#9

Updated by Frans Saris over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF