Bug #57975

No preview images on driver with basePath = /

Added by Stefan Froemken about 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-04-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

I have created a new driver with basePath=/
In such a driver no preview images will be created

I found following in LocalDriver:

// as for the "virtual storage" for backwards-compatibility, this check always fails, as the file probably lies under PATH_site
// thus, it is not checked here
// @ todo is check in storage
if (GeneralUtility::isFirstPartOfStr($localFilePath, $this->absoluteBasePath) && $this->storageUid > 0) {
    throw new \InvalidArgumentException('Cannot add a file that is already part of this storage.', 1314778269);
}

I don't understand this part. Why?

Stefan

#1

Updated by Steffen Ritter almost 7 years ago

  • Target version deleted (next-patchlevel)
#2

Updated by Daniel Goerz about 5 years ago

  • Status changed from New to Needs Feedback

This bug report is very old. Does this bug still occur in TYPO3 7 LTS and/or the master? And if so how can it be reproduced?

#3

Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF