Bug #58003

Indexed Search broken (Exception during search)

Added by Robert Vock over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2014-04-17
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using the Pi2 of Indexed Search experimental Extbase and performing a search, you get an Exception and no search results

#1: PHP Warning: Division by zero in /Users/rvock/4wdmedia/projekte/10069_bauaufsicht-frankfurt/InBearbeitung/Relaunch-Intranet_1_4/Produktion/Intranet/typo3/typo3_src/typo3/sysext/indexed_search/Classes/ViewHelpers/PageBrowsingViewHelper.php line 56

I think there are multiple bugs at work here:

1. The SearchController assigns the searchData to fluid as searchParams:

// typo3/sysext/indexed_search/Classes/Controller/SearchController.php:203
$this->view->assign('searchParams', $searchData);

But the view tries to access this data as searchData and not searchParams:

// typo3/sysext/indexed_search/Resources/Private/Templates/Search/Search.html:46
<p>
<is:pageBrowsingResults numberOfResults="{result.count}" currentPage="{searchData.pointer}" resultsPerPage="{searchData.results}" />
</p>
<is:pageBrowsing maximumNumberOfResultPages="{settings.search.page_links}" numberOfResults="{result.count}" currentPage="{searchData.pointer}" resultsPerPage="{result.pageBrowser.resultsPerPage}" />

2. result.pageBrowser is null.

3. Then the TypoScript is missing. There is no call to add it in ext_tables:

\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addStaticFile

But the TypoScript files exist in Configuration/TypoScript and the SearchController tries to access it:

if (is_array($this->settings['defaultOptions'])) {
    $searchData = array_merge($this->settings['defaultOptions'], $searchData);
}

I tested these bugs in 6.2.0 and 6.2.1


Related issues

Related to TYPO3 Core - Bug #60346: indexed_search experimental mode returns negative values in page browser Closed 2014-07-15
Related to TYPO3 Core - Bug #40279: indexed_search pi2 (extbase/fluid plugin): variable mismatch - searchData vs. searchParams Closed 2012-08-27

Associated revisions

Revision 1e27e896 (diff)
Added by Robert Vock almost 5 years ago

[BUGFIX] IndexedSearch: Fix various issues in extbase plugin

Fix these bug in the experimental extbase plugin of IndexedSearch: * TypoScript does not appear in include_static_file * Fatal error because views use variable named differently in
Controller * Pagination does not work because the form is not present on
resultpage which breaks JavaScript

Change-Id: I55962d07c543a10358298d7e9c8096c18bc0a615
Resolves: #58003
Releases: master
Reviewed-on: http://review.typo3.org/30023
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Cedric Ziel <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Sebastian Schawohl <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision c2cbc8ea (diff)
Added by Robert Vock over 4 years ago

[BUGFIX] IndexedSearch: Fix various issues in extbase plugin

Fix these bug in the experimental extbase plugin of IndexedSearch: * TypoScript does not appear in include_static_file * Fatal error because views use variable named differently in
Controller * Pagination does not work because the form is not present on
resultpage which breaks JavaScript

Change-Id: I55962d07c543a10358298d7e9c8096c18bc0a615
Resolves: #58003
Releases: 6.2
Reviewed-on: http://review.typo3.org/38626
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Markus Klein over 5 years ago

Hi Robert!

Thanks for reporting. Can you push a patch to our review system?

Cheers Markus

#2 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30023

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30023

#4 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30023

#5 Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/30023

#6 Updated by Robert Vock almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38626

#8 Updated by Robert Vock over 4 years ago

  • Status changed from Under Review to Resolved

#9 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF