Bug #40279

Epic #65814: Make Indexed search extbase plugin shine

indexed_search pi2 (extbase/fluid plugin): variable mismatch - searchData vs. searchParams

Added by Andreas Kiessling about 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2012-08-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The controller assigns this array

$this->view->assign('searchParams', $searchData);

but the pagebrowser referes to these values as searchData

<is:pageBrowsingResults numberOfResults="{result.count}" currentPage="{searchData.pointer}" resultsPerPage="{searchData.results}" />

This results e.g. in division by zero errors in this pagebrowser viewhelper


Related issues

Related to TYPO3 Core - Bug #58003: Indexed Search broken (Exception during search)Closed2014-04-17

Actions
#1

Updated by Gerrit Code Review about 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/14287

#2

Updated by Wouter Wolters over 8 years ago

  • Status changed from Under Review to Closed

Abandoned for 4.7, only secutiry fixes to that branch.

#3

Updated by Leon de Rijke over 7 years ago

This should be reopened, as it is still an issue in current stable (6.1.7).

#4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Closed to New
  • Is Regression set to No
#5

Updated by Tymoteusz Motylewski over 6 years ago

  • Parent task set to #65814
#6

Updated by Tymoteusz Motylewski over 6 years ago

  • Status changed from New to Resolved

Seems to be already fixed in v7 http://review.typo3.org/30023
see commit 1e27e8960ab195b804ab80c345fce152087d87b6

#7

Updated by Tymoteusz Motylewski over 6 years ago

  • % Done changed from 0 to 100
#8

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF