Project

General

Profile

Actions

Bug #58148

closed

If page is hidden - Content not visible in FE Preview

Added by Matthias Eberlein almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2014-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

TYPO3 6.2.2-dev Master git

If a page is in pagetree hidden, the Content is not visible when Preview in Frontend. Only on BE Module View the Content is shown.

Regards
Matthias


Files

TyposcriptFrontendController.diff (1.57 KB) TyposcriptFrontendController.diff Gerrit Mohrmann, 2014-05-10 13:19

Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Task #57814: Improve comments in TypoScriptFrontendControllerClosedmost wanted2014-04-10

Actions
Related to TYPO3 Core - Bug #59415: Admin panel : showHiddenPage and showHiddenRecords are brokenClosed2014-06-09

Actions
Has duplicate TYPO3 Core - Bug #59102: Hidden Page - content not shown in Frontend (Preview)Closed2014-05-26

Actions
Has duplicate TYPO3 Core - Bug #60230: Show hidden records from admin panal doen't workClosedNicole Cordes2014-07-10

Actions
Actions #1

Updated by Gerrit Mohrmann almost 10 years ago

Comes from http://forge.typo3.org/issues/57814

I changed two lines and have the content back.

Actions #2

Updated by Albrecht Köhnlein almost 10 years ago

Same problem for me, using 6.2.2

Actions #3

Updated by Klaus Hinum almost 10 years ago

Same here in three installations of 6.2.2

Actions #4

Updated by Klaus Hinum almost 10 years ago

patch works for me, thanks

Actions #5

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30212

Actions #6

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30212

Actions #7

Updated by Markus Klein almost 10 years ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel
  • Complexity set to easy
  • Is Regression changed from No to Yes
Actions #8

Updated by Markus Klein over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Nils Blattner over 9 years ago

Seems this not yet entirely solved.

=> TYPO3 6.2.4
=> page, hidden=1, extend to subpages
=> subpage inside which is not hidden and contains content
===> subpage is rendered, but without content

The page should not be accessible in that case.

Cheers Nils

Actions #10

Updated by Anonymous over 9 years ago

TYPO3 6.2.4 -> not resolved! doesn't metter if subpage or not, its just not possible to preview a hidden page or hidden content.
If I set a 404-handling in install-tool, the 404-page is shown in preview of a hidden page - so the normal FE-rendering is used.
That meens the preview isn't working at all!

Actions #11

Updated by Klaus Hörmann-Engl almost 9 years ago

TYPO3 6.2.6 => not resolved neither!
A frontend "PREVIEW" message is only shown on "disabled" pages or content. The option "Extend to subpages" does not extend the "disabled" option to subpages.
I also get the 404 page when I try to preview subpages, which are not hidden/disabled, underneath a hidden page with the option "Exten to subpages" set.

Actions #12

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF