Bug #58576

Cannot export content elements anymore

Added by Ivo Benner about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Import/Export (T3D)
Target version:
-
Start date:
2014-05-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When I try to export some content in the Typo3 Backend I get the following error message:

#1: PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::getSpriteIconForRecord() must be of the type array, null given, called in /var/www/t3versions/typo3_src-6.2.1/typo3/sysext/impexp/Classes/Controller/ImportExportController.php on line 583 and defined in /var/www/t3versions/typo3_src-6.2.1/typo3/sysext/backend/Classes/Utility/IconUtility.php line 723 (More information)

TYPO3\CMS\Core\Error\ErrorHandler::handleError(4096, "Argument 2 passed to TYPO3\CMS\Backend\Utility\Ico…ImportExportController.php on line 583 and defined", "/var/www/t3versions/typo3_src-6.2.1/typo3/sysext/backend/Classes/Utility/IconUtility.php", 723, array)
TYPO3\CMS\Backend\Utility\IconUtility::getSpriteIconForRecord("tt_content%3A2", NULL)

I did some logging inside ImportExportController.php and found some sort of missing URL decoding or double encoding problem:

Here is what $inData and the GET-Param tx_impexp in the ImportExportController.php looks like:

Array ( [action] => export [record] => Array ( [0] => tt_content%3A2 ) [external_ref] => Array ( [tables] => Array ( [0] => _ALL ) ) )

My URL in the Browser-Frame:

http://.../typo3/mod.php?M=xMOD_tximpexp&moduleToken=a10ff0b5cf0dd89e7ddcd8dbebb725e90a48a986&tx_impexp%5Baction%5D=export&tx_impexp%5Brecord%5D%5B0%5D=tt_content%253A2&tx_impexp%5Bexternal_ref%5D%5Btables%5D%5B0%5D=_ALL&id=2

For some reason its "tt_content%3A2" and not "tt_content:2"
Thats why all subsequent attempts in the code to explode the string by ":" fail and the error is thrown.

As far as I can tell the Error exists since I updated my Typo3 website from 6.1 to 6.2.

Any idea why this URL-encoding bug might happen ?


Related issues

Related to TYPO3 Core - Task #55671: impexp entry script cleanupClosedAnja Leichsenring2014-02-04

Actions
#1

Updated by Wouter Wolters about 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Wouter Wolters
#2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29903

#3

Updated by Wouter Wolters about 7 years ago

  • Status changed from Under Review to Accepted

Can you test the test in the reviewing system and vote if it works for you, thanks in advanced!

#4

Updated by Wouter Wolters about 7 years ago

  • Status changed from Accepted to Under Review
#5

Updated by Wouter Wolters about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus set to On Location Sprint
#7

Updated by Mathias Schreiber about 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#8

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF