Feature #58621

Format.Case ViewHelper in order to change the case of string values

Added by Bjoern Jacob almost 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Fluid
Target version:
-
Start date:
2014-05-08
Due date:
% Done:

100%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

It would be great to have a case viewhelper in TYPO3 CMS as well. See #44572 for further information.


Related issues

Related to TYPO3.Fluid - Feature #44572: Format.Case ViewHelper in order to change the case of string values Resolved 2013-01-16

Associated revisions

Revision 5e963014 (diff)
Added by Alexander Schnitzler almost 5 years ago

[FEATURE] Add a Format.Case ViewHelper

This adds a Format.Case ViewHelper that changes
a string's case in various manners like uppercase,
lowercase, (un-)capitalization and
each-word-capitalization.

Resolves: #58621
Releases: master
Change-Id: I182fae00a8bf11b6188e73bdd9cf15011ed3620d
Reviewed-on: http://review.typo3.org/36913
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Helmut Hummel <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision f1475e8d (diff)
Added by Benni Mack over 2 years ago

[TASK] Unify Backend module registration for Extbase modules

This patch unifies the Backend module registration for Extbase modules
like it has already been done for all other Backend modules using PSR-7
entry-points. This way backend route dispatching and module registration
has been simplified.

The entrypoint for Extbase Backend modules is now
\TYPO3\CMS\Extbase\Core\Bootstrap->handleBackendRequest()
which returns a PSR-7 response object.

The following functionality has been marked as deprecated as it was
solely built to handle Extbase modules when conf.php and index.php were
still in style:

ExtensionManagementUtility::configureModule()
$GLOBALS['TBE_MODULES']['_configuration'][$name]['configureModuleFunction']

Releases: master
Resolves: #82902
Related: #58621
Change-Id: I7956b350d650ed52bc7b5d83db20df386d79eb65
Reviewed-on: https://review.typo3.org/54531
Tested-by: TYPO3com <>
Reviewed-by: Henning Liebe <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Alexander Opitz over 5 years ago

  • Status changed from New to Needs Feedback

Hi,

was this issue fixed or does it still exists?

#2 Updated by Bjoern Jacob over 5 years ago

No. This issue is not fixed It's also not a bug - it's a feature. The format.case viewhelper does not exist in TYPO3 6.2. I've checked the folder /typo3/sysext/fluid/Classes/ViewHelpers/Format and there is no case viewhelper. So this would still be a great backport - maybe even for 6.2.

#3 Updated by Alexander Opitz over 5 years ago

  • Project changed from Fluid to TYPO3 Core
  • Category set to Fluid
  • Status changed from Needs Feedback to New

Ok, so it needs to be backported from TYPO3.Fluid.

#4 Updated by Bjoern Jacob over 5 years ago

Awesome!

#5 Updated by Alexander Schnitzler about 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Alexander Schnitzler

#6 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36913

#7 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36913

#8 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36913

#9 Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36913

#10 Updated by Anonymous almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF