Bug #58951

show_item does not properly resolve MM group items

Added by Xavier Perseguers over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-05-20
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When showing record information, fields which are inline records wrongly use the number of references as foreign uid to fetch related items and compute the label instead of resolving the relation.

In fact, the relations are properly resolved but never used as $this->row is not overridden by the result of the data-preprocessing.

Seems like it is bound to TYPO3 6.x because former versions did not resolve the relation and only showed the number of children.

58951-TYPO3_61.diff View - Patch for TYPO3 6.1 (1.12 KB) Xavier Perseguers, 2014-12-15 15:48

58951-TYPO3_62.diff View - Patch for TYPO3 6.2 (1.06 KB) Xavier Perseguers, 2014-12-15 16:10


Related issues

Related to TYPO3 Core - Bug #56882: Can not translate IRRE elements Closed 2014-03-13
Related to TYPO3 Core - Bug #59671: IRRE related child records are not listed (comma separated list) in list module Closed 2014-06-19
Related to TYPO3 Core - Bug #22970: t3lib_BEfunc::getProcessedValue() did not handle TCA type inline Rejected 2010-06-23

History

#1 Updated by Xavier Perseguers over 5 years ago

The call to $treatData->renderRecord() in \TYPO3\CMS\Backend\Controller\ContentElement\ElementInformationController seems to be a bad idea since native date/time fields are then converted to timestamps. Using ->renderRecordRaw() instead solves this and should not have side-effect since TSC is skipped but only used for RTE processing.

#2 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30233

#3 Updated by Tymoteusz Motylewski over 5 years ago

sounds like a similar problem to one I reported here http://forge.typo3.org/issues/56882

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30233

#5 Updated by Caspar Stuebs about 5 years ago

This Bug is related to #22970 reported since 4 Years and under review since 9 Month.

#6 Updated by Georg Ringer almost 5 years ago

  • Status changed from Under Review to Closed

has been abandoned by the author because fixed

#7 Updated by Xavier Perseguers almost 5 years ago

  • Subject changed from show_item does not properly resolve inline items to show_item does not properly resolve MM group items
  • Status changed from Closed to New
  • Target version deleted (next-patchlevel)
  • TYPO3 Version changed from 6.2 to 6.1

My original bug report must not have been clear enough, I still have the problem, specifically with "group" records using 'MM' relation:

'config' => array(
    'type' => 'group',
    'internal_type' => 'db',
    'allowed' => 'tx_myext_domain_model_member',
    'foreign_table' => 'tx_myext_domain_model_member', // MANDATORY for Extbase
    'MM' => 'tx_myext_member_memberparrain_mm',
    'size' => 3,
    'autoSizeMax' => 5,
    'maxitems' => 5,
    'multiple' => 0,
),

The problem occurs when using the "INFO" button on a record. Column containing such a definition will hold the number of selected records as "value", and this value will be used as a uid since 'MM' is not checked.

#9 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35482

#11 Updated by Xavier Perseguers almost 5 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF