Project

General

Profile

Actions

Bug #59157

closed

Linkvalidator prüft falsch!

Added by Carsten Hager about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Linkvalidator
Target version:
-
Start date:
2014-05-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Wenn ich einen Link erzeuge und aktiviere im RTE ( Enable links accessibility icons ) dann sieht mein Quelltext so aus.

<p><a href="http://www.google.de/" class="external-link" title="Öffnet externen Link im aktuellen Fenster" data-htmlarea-external="1"><img alt="Öffnet externen Link im aktuellen Fenster" src="http://p226100.mittwaldserver.info/typo3/sysext/rtehtmlarea/res/accessibilityicons/img/external_link.gif" data-htmlarea-file-uid="600" data-htmlarea-file-table="sys_file" />test</a></p>

Mein Problem ist, dass der Linkvalidator jetzt folgende URL prüft.

http://p226100.mittwaldserver.info/index.php?id=600 und nicht http://www.Google.de

Die ID 600 holt er sich aus folgendem Eintrag
data-htmlarea-file-uid="600"

Dieses Problem tritt in meinem migrierten Auftritten auf.
In einer neu installierten Umgebung mit TYPO3 6.2 hab ich diese Probleme nicht.

Bitte ins englische übersetzen, Danke.


Files


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #50772: Wrong url for links to content elementsClosed2013-08-05

Actions
Actions #1

Updated by Christoph Werner almost 10 years ago

Translation:

When creating a link in the RTE with enabled accessibility icons, some code is added to the accessibility icon (see above). The part "data-htmlarea-file-uid="600" causes the linkvalidator to treat that part like a link, which leads to an error (see screenshot).

Best Regards
Christoph

Actions #2

Updated by Alexander Stehlik almost 10 years ago

This problem seems also to be fixed with the patch for #50772 which is pending for quite some time now.

Please test and vote if it works for you.

Actions #3

Updated by Anonymous almost 10 years ago

Thank you, it works!

Actions #4

Updated by Mathias Schreiber over 9 years ago

  • Status changed from New to Resolved
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF