Project

General

Profile

Actions

Bug #59226

closed

Non-Admin can't publish page to live workspace in new session.

Added by Sven Flesch over 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2014-05-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

A member of a custom workspace can't publish a page once they have started a new session (logged out and logged in).
Publishing within the same session is not a problem!

The member can edit a live record.
The member can change the workspace stage from "editing" to "ready to publish" and back.
The member can publish other records (e.g. news).

TYPO3 4.5.34

Steps to reproduce:
1) Switch to custom workspace.
2) Create page.
3) Start new session (log out, log in)
4) Try to publish the page.

Expected result:
- Page gets published and is removed from Web->Workspaces view.

What actually happens:
- Nothing. Web->Workspaces stays the same, the record is still selected (checkbox).
- No error message is given.


Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Bug #70687: Workspace autopublish does not recurse through mountpointsClosedErik Frister2015-10-14

Actions
Actions #1

Updated by Sven Flesch over 9 years ago

  • % Done changed from 0 to 100

Fixed it.
If no new page is created, the be_acl cache is not updated.
To fix it I added a hook that does just that:
$GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['t3lib/class.t3lib_tcemain.php']['clearCachePostProc']

be_acl\class.tx_beacl_hooks.php has a working example.

Actions #2

Updated by Mathias Schreiber about 9 years ago

  • Target version set to 7.5
Actions #3

Updated by Oliver Hader over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version changed from 7.5 to 7 LTS

Does that behavior occur in the recent TYPO3 CMS 7.4 version (and/or master)?
Does it occur at all, if the be_acl extension is not installed?

Actions #4

Updated by Oliver Hader over 8 years ago

  • Priority changed from Must have to Should have
  • Target version changed from 7 LTS to next-patchlevel
  • TYPO3 Version changed from 4.5 to 6.2
Tested in 6.2.16-dev with non-admin.
  • something seems to be wrong if the mass actions are used (no changes at all)
  • using the dedicated actions by clicking the checkbox works however
Actions #5

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44416

Actions #6

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44417

Actions #7

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44417

Actions #8

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44417

Actions #9

Updated by Oliver Hader over 8 years ago

  • Status changed from Under Review to Resolved
Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF