Project

General

Profile

Actions

Bug #70687

closed

Workspace autopublish does not recurse through mountpoints

Added by Erik Frister over 8 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2015-10-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Setting up a workspace to be autopublished through the scheduler (which will publish via _cli_scheduler user) does not work correctly currently.

The reason is that only versions on the mountpages for the user _cli_scheduler are used; they are not being recursed correctly. Fix is the set recursion to infinite for the AutoPublish.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #59226: Non-Admin can't publish page to live workspace in new session.Closed2014-05-30

Actions
Actions #1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44055

Actions #2

Updated by Erik Frister over 8 years ago

To test:

- Create a workspace and set it to publish at a time in the past
- Make changes to content/pages in the new workspace that are on a leaf page (i.e. not a mountpage of a non-admin user)
- Give _cli_scheduler user the permissions to publish in the workspace
- Create Autopublish scheduler task and set to run once
- Let it execute

Expected:
All changes are published, regardless of where they are in the page tree

Actual (currently):
Only content on mountpages of the _cli_scheduler users is published. The tree is not recursed at all.

Actions #3

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (next-patchlevel)
Actions #4

Updated by Markus Sommer over 8 years ago

  • Assignee set to Erik Frister
Actions #5

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44055

Actions #6

Updated by Oliver Hader over 8 years ago

  • Status changed from Under Review to Resolved

The mentioned behavior already bas been solved with #59226 since the auto-publish task is executed with a non-privileged backend user in CLI/scheduler context...

Actions #7

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF