Bug #59829

Uncaught TYPO3 Exception #1310027933

Added by Lieuwe Hummel over 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-06-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

An exception occured during the rendering of an Extbase query in a custom extension. My method in the repository:

public function findAllByGroupUid($groupUid) {
    $query = $this->createQuery();
    $query->matching(
        $query->equals('group', intval($groupUid))
    );
    $query->setOrderings(array(
        'title' => $query::ORDER_ASCENDING,
    ));
    return $query->execute();
}

The error which occured:

Uncaught TYPO3 Exception
#1310027933: DBAL fatal error: No handler found in handler_getFromTableList() for:
"" (SQL engine parse ERROR: No table name found as expected in parseFromTables()!:
near " ") (More information)

RuntimeException thrown in file
/var/www/vhosts/mysite.local/typo3_src/typo3/sysext/dbal/class.ux_t3lib_db.php in line 3028.

Cause:
When analyzing the call stack (see also http://wiki.typo3.org/Exception/CMS/1310027933) call #42 states this:

$this->replacePlaceholders($statement, $parameters, $statementParts['tables'][0]);

$statementParts has been initialized with a hashed index for $statementParts['tables'], not a numbered index, see Tx_Extbase_Persistence_Storage_Typo3DbBackend::parseSource(). The call to replacePlaceholders() will logically fail because of this.

Workaround 1: uninstall EXT:dbal
Workaround 2: apply attached patch. No negative effects have been found by my (limited) testing, but I'm not sure if this is the correct solution.

Bug affects TYPO3 CMS v4.5.35-dev and v4.7.20-dev, possibly others


Files

workaround2.diff (734 Bytes) workaround2.diff Lieuwe Hummel, 2014-06-23 23:01
#1

Updated by Markus Klein over 7 years ago

  • Status changed from New to Needs Feedback

Is this also present on current master or 6.2?
If not, we will not take the time to look into this. 4.7 is too old and is in priority bugfix mode.

#2

Updated by Lieuwe Hummel over 7 years ago

I tried to test it on 6.2 as well, but my website required too much effort to make it compatible, consuming time I don't have available for this project. My answer: I don't know.

#3

Updated by Markus Klein over 7 years ago

Ok, thanks for trying at least. We will leave that open with that question, so in case somebody has the same issue, he/she may find this issue and reports. Thanks Lieuwe.

#4

Updated by Alexander Opitz almost 7 years ago

After 4 months with no more response I'd like to close this issue. Ok?

#5

Updated by Lieuwe Hummel almost 7 years ago

No problem with me, but I hoped to see this resolved in code with my patch... ;)

#6

Updated by Alexander Opitz almost 7 years ago

So find out if the issue exists in 6.2 ;-)

#7

Updated by Benni Mack almost 7 years ago

  • Status changed from Needs Feedback to Closed

Code was refactored with 6.2 so this problem seems to be fixed as the existing problem (and workaround) is not applicable anymore!

Thanks for digging into this!

Also available in: Atom PDF