Feature #60522

Sorting of custom records in List Module

Added by christian rauch over 5 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-07-24
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:
PRC

Description

If I add custom records to the page module with $TYPO3_CONF_VARS['EXTCONF']['cms']['db_layout']['addTables'] sorting is not possible.

the makeOrdinaryList function makes a call to $this->fwd_rwd_nav() but I dont get the Logic behind it, as it always return an array with two elements (0=>1, 1=>0)

        while ($row = $this->getDatabase()->sql_fetch_assoc($result)) {
            BackendUtility::workspaceOL($table, $row);
            if (is_array($row)) {
                *list($flag, $code) = $this->fwd_rwd_nav();
                $out .= $code;*
                if ($flag) {
                    $params = '&edit[' . $table . '][' . $row['uid'] . ']=edit';
                    $Nrow = array();
                    // Setting icons links
                    if ($icon) {
                        $Nrow['__cmds__'] = $this->getIcon($table, $row);
                    }
                    // Get values:
                    $Nrow = $this->dataFields($this->fieldArray, $table, $row, $Nrow);
                    // Attach edit icon
                    if ($this->doEdit) {
                        $Nrow['__editIconLink__'] = '<a href="#" onclick="' . htmlspecialchars(
                                BackendUtility::editOnClick($params, $this->backPath))
                            . '" title="' . $this->getLanguageService()->getLL('edit', TRUE) . '">'
                            . IconUtility::getSpriteIcon('actions-document-open') . '</a>';
                    } else {
                        $Nrow['__editIconLink__'] = $this->noEditIcon();
                    }
                    $out .= $this->addelement(1, '', $Nrow, 'class="db_list_normal"');
                }
                $this->eCounter++;
            }
        }

This is the only thing that prevents me from disabling the list module entirely in my use cases. I think it would be a great addition to typo3 because most editors are somehow confused when i explain the difference between the list and the page module to them.

I tried to implement it myself, but I failed because I don't understand enough of the typo3 core

History

#1 Updated by christian rauch over 5 years ago

sorry about the stars in the code example... wanted to make it bold but of course this doesn't work in a pre section

#2 Updated by Susanne Moog over 4 years ago

  • Sprint Focus set to PRC

#3 Updated by Riccardo De Contardi about 4 years ago

  • Category set to Backend User Interface

#4 Updated by Christian Kuhn almost 3 years ago

  • Status changed from New to Rejected

rejecting:

no further info for a long time, the issue is sort-of unclear, and i'm totally unsure on what is actually meant.

if you think we should re-discuss this issue, please open a new one.

Also available in: Atom PDF