Bug #60913

Cannot edit lazy loaded objects

Added by Mathias Brodala almost 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2014-08-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Lazy loaded objects cannot be edited through Fluid forms.

Given the following form:

<f:form name="bar" object="{foo.bar}">
  <f:form.textfield property="propertyOfBar"/>
  <f:form.submit value="Update"/>
</f:form>

If "bar" of "foo" is an instance of TYPO3\CMS\Extbase\Persistence\Generic\LazyLoadingProxy the initial check in TYPO3\CMS\Fluid\ViewHelpers\Form\AbstractFormViewHelper::renderHiddenIdentityField fails because the LazyLoadingProxy instance cannot be an instance of TYPO3\CMS\Extbase\DomainObject\AbstractDomainObject. This prevents the hidden identity field from being rendered which makes editing impossible.


Files

fluid-form-lazyloadingproxy.patch (895 Bytes) fluid-form-lazyloadingproxy.patch Load lazy loading proxy on rendering hidden identity field Mathias Brodala, 2014-08-12 14:01

Related issues

Related to TYPO3 Core - Feature #60460: Refactor lazyLoading handling in extbaseClosedFelix Oertel2014-07-22

Actions
Is duplicate of TYPO3 Core - Bug #60726: __identity field will not be rendered if of type @lazyClosed2014-08-01

Actions
#1

Updated by Stefan Froemken over 6 years ago

  • Status changed from New to Resolved
#2

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF