Bug #60926

Epic #58282: Workspaces Workpackage #2

Story #58284: Bug fixes & Behaviour

Cannot use slot to modify grid data array in workspace module

Added by Oliver Hader about 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2014-08-13
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using slots in GridDataService does not work since passing arguments by reference does not work.
Since TYPO3 CMS 6.2 it's possible that the SignalSlotDispatcher returns (modified) arguments.

Associated revisions

Revision 9c28ad7f (diff)
Added by Oliver Hader about 4 years ago

[BUGFIX] Workspaces: Properly use slots to modify data

Using slots in GridDataService does not work since passing
arguments by reference does not work. Since TYPO3 CMS 6.2
it's possible that the SignalSlotDispatcher returns
(modified) arguments.

Resolves: #60926
Releases: master, 6.2
Change-Id: If7f3a782bf8870bfb158c566df01cf2311fce048
Reviewed-on: http://review.typo3.org/32120
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

Revision a1e8db1a (diff)
Added by Oliver Hader about 4 years ago

[BUGFIX] Workspaces: Properly use slots to modify data

Using slots in GridDataService does not work since passing
arguments by reference does not work. Since TYPO3 CMS 6.2
it's possible that the SignalSlotDispatcher returns
(modified) arguments.

Resolves: #60926
Releases: master, 6.2
Change-Id: If7f3a782bf8870bfb158c566df01cf2311fce048
Reviewed-on: http://review.typo3.org/41191
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

Revision 21a105eb (diff)
Added by Benni Mack about 4 years ago

[FOLLOWUP][BUGFIX] Workspaces: Properly use slots to modify data

Using slots in GridDataService does not work since passing
arguments by reference does not work. Since TYPO3 CMS 6.2
it's possible that the SignalSlotDispatcher returns
(modified) arguments.

Change-Id: I6a5e123bfc0d44d484e5b432e65a4d6cb50b75fb
Resolves: #60926
Releases: 6.2
Reviewed-on: http://review.typo3.org/41209
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32120

#2 Updated by Oliver Hader about 5 years ago

  • Parent task set to #58284

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32120

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32120

#5 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.5

#6 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32120

#7 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32120

#8 Updated by Oliver Hader about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41191

#10 Updated by Oliver Hader about 4 years ago

  • Status changed from Under Review to Resolved

#11 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41209

#12 Updated by Gerrit Code Review about 4 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41209

#13 Updated by Benni Mack about 4 years ago

  • Status changed from Under Review to Resolved

#14 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF