Bug #61635

Click-enlarge images with missing data-htmlarea-file-uid lead to error in rendering the page

Added by Klaus Hinum over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-09-16
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We noticed the bug when editing a big table with embedded images using the RTE and the source itself. Somehow the data-htmlare-file-uid and file-table fields were missing (editor stripping it in some cases?) and afterwards the page did not render anymore in the frontend with the error.

Fatal error: Call to a member function getUid() on a non-object in typo3_src-6.2.4/typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php on line 1495

Removing the clickenlare="1" or adding the data-htmlarea-file-uid and table again, fix the issue.

HTML Source, working image with click enlarge:

<img src="fileadmin/_processed_/image.png" width="100" height="149" data-htmlarea-file-uid="1872377" data-htmlarea-file-table="sys_file" title="" alt="" data-htmlarea-clickenlarge="1" />

not working image leading to the getUid fatal error:

<img src="fileadmin/_processed_/image.png" width="100" height="150" title="" alt="" data-htmlarea-clickenlarge="1"/>


Related issues

Related to TYPO3 Core - Bug #62686: RTE clickenlarge Closed 2014-11-04

History

#1 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Needs Feedback

Hi, sorry for the late answer.

can you tell us if the issue still happens with 6.2.15 or 7.6-dev (latest master)? Or can you write the exact procedure to reproduce it?
Thank you!

#2 Updated by Riccardo De Contardi about 3 years ago

I am failing in reproducing it with 6.2.17; can you confirm? Thank you!

#3 Updated by Sven Burkert about 3 years ago

Seems to be fixed now.

#4 Updated by Wouter Wolters about 3 years ago

  • Status changed from Needs Feedback to Closed

Reported as fixed. Closing the issue.

Also available in: Atom PDF