Project

General

Profile

Actions

Bug #61686

closed

User group filter in in Backend users module lacks sorting

Added by Andreas Kie├čling almost 10 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-09-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

The options in the "User group" filter in the "Backend users" module are not sorted by title. With a lot of groups, this is very confusing. Since the be_groups table is sorted by title in the list module, the same sorting should be applied here by adding a default ordering to the BackendUserGroupRepository

\TYPO3\CMS\Beuser\Domain\Repository\BackendUserGroupRepository

protected $defaultOrderings = array(
    'title' => \TYPO3\CMS\Extbase\Persistence\QueryInterface::ORDER_ASCENDING
);
Actions

Also available in: Atom PDF