Project

General

Profile

Actions

Bug #61747

closed

Depending on how we delete something in RTE, we get different results after saving

Added by Olga Otkupchyk almost 10 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-09-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello,

our Failure is similar with:
https://forge.typo3.org/issues/32263

We have tested the following cases with different results on TYPO3 6.2:

1. Use the mouse to mark something, then delete it using keyboard (del or back)
-> This could not delete formatblock and we found <p> </p> after saving in our source code.

2. Use "CTRL + A", then delete it using keyboard (del or back)
-> No formatblock after saving

Is it possible to fix it? Maybe it's a faulty configuration in RTE?

Thanks for your help
Olga Otkupchyk


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #32263: HTML entity &nbsp; is inserted before and after HTML TagsClosedStanislas Rolland2011-12-02

Actions
Actions #1

Updated by Steffen Müller over 9 years ago

  • Tracker changed from Suggestion to Bug
  • Project changed from 1865 to TYPO3 Core
  • Category deleted (User interface)

Moved from Logging Project tracker

Actions #2

Updated by Stanislas Rolland over 9 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Is Regression set to No
Actions #3

Updated by Gerrit Code Review over 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33497

Actions #4

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33497

Actions #5

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33498

Actions #6

Updated by Stanislas Rolland over 9 years ago

  • Assignee set to Stanislas Rolland
  • Target version set to next-patchlevel

I assume you are testing with Firefox.

Please test this change: https://review.typo3.org/#/c/33498/

Actions #7

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33497

Actions #8

Updated by Olga Otkupchyk over 9 years ago

We tested your patch in Firefox (v. 32.0.3) . The test was successful.
Internet Explorer 11 ist not fixed yet.
Thanks for your support.

Actions #9

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33497

Actions #10

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33498

Actions #11

Updated by Stanislas Rolland over 9 years ago

Please test Patch Set 2: https://review.typo3.org/#/c/33498/

Actions #12

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF